summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-28 22:17:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-28 22:17:42 +0200
commit4319da76fcff6df2c86b9c3e8fdfd506fdcdec8f (patch)
tree2575f13b64d3d8b4f35572e321c27db8a1503825
parentdev-python/botocore: Bump to 1.22.6 (diff)
downloadgentoo-4319da76fcff6df2c86b9c3e8fdfd506fdcdec8f.tar.gz
gentoo-4319da76fcff6df2c86b9c3e8fdfd506fdcdec8f.tar.bz2
gentoo-4319da76fcff6df2c86b9c3e8fdfd506fdcdec8f.zip
dev-python/boto3: Bump to 1.19.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.19.6.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 0a5bf109b2c3..74d982882033 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.18.53.tar.gz 422176 BLAKE2B a07155f6be71c049479c1d2e47767bb2c686307
DIST boto3-1.18.60.tar.gz 428327 BLAKE2B d559c7512c7ab1160dfec4616741002ce82357d3469747044bf79f90baba5e6e3d2f2ecf32ae4cad7522a341d846d199cf34555376d05d56cdbfccc75d0f9042 SHA512 e013ec97b4379cbd3f21f000974d8078a2710f29a9a7d34532fa06c9011fb566238d38d45abd5ecad5b26ad544f72b86ae191fe475bd0d729d290553cd461ff8
DIST boto3-1.18.65.tar.gz 429858 BLAKE2B fbc80e0d8d10f6d02fcf9b86c6b4be03a9c908318c507a7cde1eef0c36d8fe3a5d3be0f8c6178edfdd8bc82adf112f297a5f127cd2b442ce10fe4d37b3a21fa4 SHA512 631d8f618fb6d55b338b563e72e1ccc751b8937bb2660d033b885951ea5ec3ac6902f8c7b9918664d764be84fdef5af4e7a87d444cbc154ebf5ae06908f90714
DIST boto3-1.19.5.tar.gz 433567 BLAKE2B 52c12a4dd18d6f02326f8002b345cc5df224455fc862daa700326ae1df258979211d2753f01e1a106f237de393e483dc8926bb4ef0e08bafa575f20811dccd55 SHA512 fad05102f0c3e7e30a3342009f6b3ae28f52758f17a0c22b4da9a03dd10d7f9149ea2ec0119f55ec7280824bd8173653271821e82fcd54ef9fb9161b2d62df70
+DIST boto3-1.19.6.tar.gz 434389 BLAKE2B 3c7e4c91c95b93358b4a31d401e03f8a397802004a6ee2bfc2ef1a31df8b89e8866fa73d3354509ae00537898cc8e04b878cc9d00f82ae4e94266e8185e7abd1 SHA512 6ba4f7a89d973991afe329b4c648c8ecb0bb256d63c7e60ae8bb70e6fd5fc9b1929168dfdd55f2c84039856a32c891013abf61dc2e65f516490c446b0dfaaac2
diff --git a/dev-python/boto3/boto3-1.19.6.ebuild b/dev-python/boto3/boto3-1.19.6.ebuild
new file mode 100644
index 000000000000..450c87d9f8b7
--- /dev/null
+++ b/dev-python/boto3/boto3-1.19.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}