summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-10-16 12:26:14 -0700
committerMatt Turner <mattst88@gentoo.org>2018-10-16 12:29:56 -0700
commit432eab68610b0f58facd62b5835d5abf4e1e2b6e (patch)
tree28b7bbe71ff472b7819d2c63f96334f4f8d81a56
parentdev-libs/wayland: Drop ltprune (diff)
downloadgentoo-432eab68.tar.gz
gentoo-432eab68.tar.bz2
gentoo-432eab68.zip
dev-libs/wayland: Version bump to 1.16
Closes: https://bugs.gentoo.org/668770 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/wayland/Manifest1
-rw-r--r--dev-libs/wayland/wayland-1.16.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
index 9e0aa19b30ea..90b92d2812ca 100644
--- a/dev-libs/wayland/Manifest
+++ b/dev-libs/wayland/Manifest
@@ -1 +1,2 @@
DIST wayland-1.15.0.tar.xz 432932 BLAKE2B d86e5ba52c16664926e4688317db3fad4f9629c3903239dde46ee238ef7874f28e39daa6bbda96519dfda4ff83a1f540522f21fbabe9b71aa263523481d4eb5b SHA512 f908917f1b575d2dc4d9770d3303e2637e8744fcb5c81feb2af2fe82cc51f54e22beaddfbe775fcf9623584169b7a062c75076132abeb888717180bfab53b3a8
+DIST wayland-1.16.0.tar.xz 435216 BLAKE2B 862cc8ca9da060f9b8345aa0a62a4af76a31562246b75d2679bcf30cc894cc94ec28f97951f766b6e5297b2e113cd8b08e5682dacbfc79544c0085995693ec55 SHA512 64eca2b1c0bc7913508a5499dae87e2723c712d8024acbb4c77c3c4a6c20de78c10704ae9827fd034116ca540a547aeec28c5a1e3bd382b23f85231424b0f49c
diff --git a/dev-libs/wayland/wayland-1.16.0.ebuild b/dev-libs/wayland/wayland-1.16.0.ebuild
new file mode 100644
index 000000000000..fccfe91aa57e
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.16.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit autotools libtool multilib-minimal toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
+ >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:=
+ !!<media-libs/mesa-18.1.1-r1"
+DEPEND="${RDEPEND}
+ doc? (
+ >=app-doc/doxygen-1.6[dot]
+ app-text/xmlto
+ >=media-gfx/graphviz-2.26.0
+ sys-apps/grep[pcre]
+ )
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ $PV = 9999* ]] && eautoreconf || elibtoolize
+}
+
+multilib_src_configure() {
+ local myconf
+ if tc-is-cross-compiler ; then
+ myconf+=' --with-host-scanner '
+ fi
+
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ $(multilib_native_use_enable doc documentation) \
+ $(multilib_native_enable dtd-validation) \
+ ${myconf}
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete || die
+ einstalldocs
+}
+
+src_test() {
+ # We set it on purpose to only a short subdir name, as socket paths are
+ # created in there, which are 108 byte limited. With this it hopefully
+ # barely fits to the limit with /var/tmp/portage/$CAT/$PF/temp/xdr
+ export XDG_RUNTIME_DIR="${T}"/xdr
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ multilib-minimal_src_test
+}