summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-10-22 11:01:29 -0300
committerMatt Turner <mattst88@gentoo.org>2022-10-25 11:25:04 -0400
commit43421ec231f5ac6741abae16a3b36b5373352518 (patch)
treea3b440a4c482d541f0cd539db5f3741b1ed2570a
parentgnome-extra/gucharmap: Version bump to 15.0.1 (diff)
downloadgentoo-43421ec2.tar.gz
gentoo-43421ec2.tar.bz2
gentoo-43421ec2.zip
sci-geosciences/gnome-maps: Version bump to 43.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-43.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 34e2c345f3b7..ae98f9e4d981 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,2 +1,3 @@
DIST gnome-maps-42.3.tar.xz 2317328 BLAKE2B 365eb5cb8f7b20e2069338249418f5fad1abd47a1ab7ecda2d671dc97dfa45fb9f5687ae01fd605613c7ecf6eb9048aef6ab121cac0f455a42df9156581c87e2 SHA512 e52509603914de8f345a874f931beb68d11f718827b956a48464fe804c42559d977eacb0bbd5d4346b6329ab3f9169ac9afa8ef681f040c5b6a82b440b9786cb
DIST gnome-maps-43.0.tar.xz 2330656 BLAKE2B 117a3558e29abe6a1bd29cf347b20a9e33f2b1cabd5310f28e387685e0bde96d1ce371c88616914f298e25ffbbc72b4d29e4fa721994b184e88289c6d0236ea0 SHA512 70966d6a092a67eb6a3a62627666376a71767d9296e00489a5aff281793425d9edd5e978deaf47bbd7d6b0ce37b53cf724b73487e101554c7984456661e193fc
+DIST gnome-maps-43.1.tar.xz 2329212 BLAKE2B 6597597dcf5b056a33670f502c3ab0b9658b6cac5e72896f5363034649ddf01fe9ae2a275dbd1a298b0dd1850b8a9c625fff02a15c998fd0e296f794aedf7b0e SHA512 f4eafdf6b81a23567d526ae51842e391c7b3e585967abb2b6a38ab1a361de77a69ebbf01939f3a328990fe3f623f4bd40a720f776c27af07acb27b2222b75a12
diff --git a/sci-geosciences/gnome-maps/gnome-maps-43.1.ebuild b/sci-geosciences/gnome-maps/gnome-maps-43.1.ebuild
new file mode 100644
index 000000000000..60b7b5097144
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-43.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.0:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ >=media-libs/libshumate-1.0:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}