summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-26 01:00:00 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-26 01:01:28 -0700
commit4364658df0ff6f92297648a32dbd28efac732e80 (patch)
tree1a156e48018531f7b8a227fb526929bb00378a79
parentmedia-libs/libtgvoip: bump to new snapshot (diff)
downloadgentoo-4364658d.tar.gz
gentoo-4364658d.tar.bz2
gentoo-4364658d.zip
net-im/telegram-desktop: bump to 2.4.4
webrtc is imposibble to turn off for now, unfortunately. webrtc alsa and pulseaudio will be forced on for now. add system-rlottie useflag. for now tg_owt bundles the following: openh264 abseil-cpp libsrtp libvpx libyuv pffft rnnoise usrsctp Bug: https://bugs.gentoo.org/736774 Bug: https://bugs.gentoo.org/749288 Closes: https://bugs.gentoo.org/739466 Closes: https://bugs.gentoo.org/707272 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--net-im/telegram-desktop/Manifest2
-rw-r--r--net-im/telegram-desktop/metadata.xml2
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.4.4.ebuild184
3 files changed, 188 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index 23c15929c96c..21d78ca38a6b 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1,2 +1,4 @@
DIST tdesktop-2.1.13-full.tar.gz 36549505 BLAKE2B 48514be8add4ad4491c8e81a868f140228787ee489de7cd90faf31dbee959b0fb87cf2c844bf98c5b62fd6de8e32f504a6d19b071c56e6a4c0cd489d7b283818 SHA512 f28ae7c8c9a9eb8094fc52784742b470235234a3df7487902152858bc7c297b2dcfe5c8b939cdb9653a356b3835609e7289f53cdf7d5fb3f009823d3dbeb1bd8
DIST tdesktop-2.2.0-full.tar.gz 36612169 BLAKE2B dcc9d81da5d99552bea3139d595c7f1aca75464a19be34c880a93d27ddd8a58a01510efe8fde31104b13d50e34e944b05406e21bc96995e85cb95283ff8de08a SHA512 2aeca83be7bc385bd7537d56ecf66996facedd0af588e743fedbb08c3158fc76436d6cf3b1fb5dd7c8d37b4471f739872ca54ba300aa1d0e0202e87c005703fd
+DIST tdesktop-2.4.4-full.tar.gz 36220573 BLAKE2B 2c339e576cdc8877fee7966c34b3ea0119c547422c67af3252102a52de95b9b03c2ecee48a0e937cb1cac43262338aca9d90921012dec17dc4f9b6a9154c63c1 SHA512 db212cc9aef7de21e4e4fa30fdabb88224cda5ab164935de118cab507af730f5773602f8cd7acd83a53daa5bf35fe28fdb18fb192c01e2e484069a9ac69c7c57
+DIST tg_owt-c73a4718cbff7048373a63db32068482e5fd11ef.tar.gz 18389536 BLAKE2B 467bc980c3fe924b8753153052126c209984884b43d2257b0a9ead4abd9b27c96c9b6f93b1e1345abde5a23feef8b40d05f75eb95fb215783ec8d775dbcc14eb SHA512 b022e77bc3ebce0a42bd40f781b5ff2b8222f44c9ebacb8f6d5581fe04fa7bbb6faf29ee9a090da3aee322bc581feeab375b2ab6dd9aab084627327b191c1d7a
diff --git a/net-im/telegram-desktop/metadata.xml b/net-im/telegram-desktop/metadata.xml
index 5eb4b12ceaa6..487d6100c6b0 100644
--- a/net-im/telegram-desktop/metadata.xml
+++ b/net-im/telegram-desktop/metadata.xml
@@ -8,5 +8,7 @@
<use>
<flag name="enchant">Enable the app-text/aspell spell-checking backend</flag>
<flag name="hunspell">Enable the app-text/hunspell spell-checking backend</flag>
+ <flag name="system-rlottie">Use system version of <pkg>media-libs/rlottie</pkg> ( may alter sticker color )</flag>
+ <flag name="webrtc">WebRTC based video call support</flag>
</use>
</pkgmetadata>
diff --git a/net-im/telegram-desktop/telegram-desktop-2.4.4.ebuild b/net-im/telegram-desktop/telegram-desktop-2.4.4.ebuild
new file mode 100644
index 000000000000..6f411ab81e1e
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-2.4.4.ebuild
@@ -0,0 +1,184 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit cmake desktop flag-o-matic ninja-utils python-any-r1 xdg-utils
+
+MY_P="tdesktop-${PV}-full"
+TG_OWT_COMMIT="c73a4718cbff7048373a63db32068482e5fd11ef"
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz
+ webrtc? (
+ https://github.com/desktop-app/tg_owt/archive/c73a4718cbff7048373a63db32068482e5fd11ef.tar.gz -> tg_owt-${TG_OWT_COMMIT}.tar.gz
+ )
+"
+
+LICENSE="GPL-3-with-openssl-exception LGPL-2+
+ !system-rlottie? ( BSD FTL JSON MIT )
+ webrtc? ( BSD )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="+alsa +dbus enchant +gtk +hunspell libressl +pulseaudio +spell system-rlottie +webrtc +X"
+
+RDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ app-arch/xz-utils
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ dev-libs/xxhash
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[dbus?,jpeg,png,wayland,X(-)?]
+ dev-qt/qtimageformats:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5[png,X(-)?]
+ media-fonts/open-sans
+ media-libs/fontconfig:=
+ ~media-libs/libtgvoip-2.4.4_p20200818[alsa?,pulseaudio?]
+ media-libs/openal[alsa?,pulseaudio?]
+ media-libs/opus:=
+ media-video/ffmpeg:=[alsa?,opus,pulseaudio?]
+ sys-libs/zlib[minizip]
+ virtual/libiconv
+ x11-libs/libxcb:=
+ dbus? (
+ dev-qt/qtdbus:5
+ dev-libs/libdbusmenu-qt[qt5(+)]
+ )
+ enchant? ( app-text/enchant:= )
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2[jpeg,X?]
+ x11-libs/gtk+:3[X?]
+ x11-libs/libX11
+ )
+ hunspell? ( >=app-text/hunspell-1.7:= )
+ pulseaudio? ( media-sound/pulseaudio )
+ webrtc? ( media-libs/libjpeg-turbo:= )
+ system-rlottie? ( media-libs/rlottie:= )
+"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+ dev-cpp/range-v3
+ =dev-cpp/ms-gsl-3*
+"
+
+BDEPEND="
+ >=dev-util/cmake-3.16
+ virtual/pkgconfig
+ webrtc? ( amd64? ( dev-lang/yasm ) )
+"
+
+REQUIRED_USE="
+ || ( alsa pulseaudio )
+ spell? (
+ ^^ ( enchant hunspell )
+ )
+ webrtc? ( alsa pulseaudio )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if has ccache ${FEATURES}; then
+ ewarn
+ ewarn "ccache does not work with ${PN} out of the box"
+ ewarn "due to usage of precompiled headers"
+ ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+ ewarn
+ fi
+}
+
+src_unpack() {
+ default
+ use webrtc && mv -v "${WORKDIR}/tg_owt-${TG_OWT_COMMIT}" "${WORKDIR}/tg_owt"
+}
+
+build_tg_owt() {
+ einfo "Building tg_owt / webrtc"
+ mkdir -v "${WORKDIR}/tg_owt_build" || die
+ pushd "${WORKDIR}/tg_owt_build" > /dev/null || die
+ cmake -G Ninja -DCMAKE_BUILD_TYPE=Release -DTG_OWT_PACKAGED_BUILD=ON ../tg_owt || die
+ eninja
+ popd > /dev/null || die
+}
+
+src_configure() {
+ local mycxxflags=(
+ -Wno-deprecated-declarations
+ -Wno-error=deprecated-declarations
+ -Wno-switch
+ )
+
+ append-cxxflags "${mycxxflags[@]}"
+
+ # we have to build tg_owt now before running telegram's cmake
+ use webrtc && build_tg_owt
+
+ # TODO: unbundle header-only libs, ofc telegram uses git versions...
+ # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
+ # EXPECTED VARIANT
+ # gtk is really needed for image copy-paste due to https://bugreports.qt.io/browse/QTBUG-56595
+ local mycmakeargs=(
+ -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
+ -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
+ -DDESKTOP_APP_USE_PACKAGED=ON
+ -DDESKTOP_APP_USE_PACKAGED_FONTS=ON
+ -DDESKTOP_APP_LOTTIE_USE_CACHE=$(usex system-rlottie OFF ON) # we disable cache with system rlottie
+ -DTDESKTOP_DISABLE_GTK_INTEGRATION="$(usex gtk OFF ON)"
+ -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
+ -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
+ -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)" # enables hunspell (recommended)
+ -DDESKTOP_APP_DISABLE_WEBRTC_INTEGRATION="$(usex webrtc OFF ON)" # requires pulse AND alsa
+ -DDESKTOP_APP_USE_ENCHANT="$(usex enchant ON OFF)" # enables enchant and disables hunspell
+ $(usex webrtc "-Dtg_owt_DIR=${WORKDIR}/tg_owt_build" '')
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ use gtk || einfo "enable 'gtk' useflag if you have image copy-paste problems"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}