summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-02-02 09:18:32 +0800
committerYixun Lan <dlan@gentoo.org>2022-02-02 09:18:32 +0800
commit437de54a80402dd30c811cbb0d0b73d4a31d5574 (patch)
tree1465d9bb7a8eac883cbe325d163a619cccddb1f6
parentdev-util/unicorn: update for distutlis-r1.eclass' DISTUTILS_DEPS var (diff)
downloadgentoo-437de54a.tar.gz
gentoo-437de54a.tar.bz2
gentoo-437de54a.zip
net-misc/ofono: version bump 1.34
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--net-misc/ofono/Manifest1
-rw-r--r--net-misc/ofono/ofono-1.34.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/ofono/Manifest b/net-misc/ofono/Manifest
index 6c678670a5d0..60dde38a982c 100644
--- a/net-misc/ofono/Manifest
+++ b/net-misc/ofono/Manifest
@@ -1,2 +1,3 @@
DIST ofono-1.31.tar.xz 1049252 BLAKE2B f7b40d3aa7854369a7886a4b64bb66044e8f016682665935f7727bf219c084d266d8fd7f80c97e58234d845f7db3dc52133298697274745d115cf14c62769d82 SHA512 377cda34dcc92d1f339a4b3271de5a14afaf309061c4467e5af18089cd821e65c0d8ad29d07e96d0f0480bb51554b284afb6bc2b9da586cc30dc0c1440612b20
DIST ofono-1.33.tar.xz 1060408 BLAKE2B 646a96c0926ea032fef0357aabe6a4be6da88f4ccbdff59bb86b5de73a9b469362151b212a05234619f5d616b534343137c66e923782c7d50dfe13d2bf66558c SHA512 8d88226aa2b43eca840c6330045ee7a96c91f6003b06fca5ea55b74fc229f0e0ba0c8d98f7945f8c23ec5a8e7057bffef6335c61842e245686e0ed7c5feda589
+DIST ofono-1.34.tar.xz 1060828 BLAKE2B be0d3787ca9226763fb2bff46f1c3cec813d702730d6231986ec5aa43e2d96e08385fa3f64ccff97cf15844e41a33d6c37d1d35c8b0c5fcf3765848e258e3372 SHA512 79ebf0bc795288f07b58eeaa1a0aa3309b4afecae3abdd26c0749e22a4c2e74b65e93cbcfdfd1738dbcb2d0cfb8c687d182d706696a7c1cd5b4ed3bcec059489
diff --git a/net-misc/ofono/ofono-1.34.ebuild b/net-misc/ofono/ofono-1.34.ebuild
new file mode 100644
index 000000000000..1afaf2e3612b
--- /dev/null
+++ b/net-misc/ofono/ofono-1.34.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="https://01.org/ofono"
+SRC_URI="https://www.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem tools +udev upower"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.6
+ >=dev-libs/glib-2.68
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable cdmamodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable provision) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ $(use_enable upower) \
+ --disable-maintainer-mode \
+ --disable-rilmodem
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-provider-name \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}