summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-07-24 22:27:44 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-07-24 22:27:44 -0400
commit437eb41205b8f17951caee1c2b26c4812caa0225 (patch)
tree5604ec0de2b04dc96684ad0a5abfa9fa902ca449
parentdev-python/python-netlink: new package (diff)
downloadgentoo-437eb41205b8f17951caee1c2b26c4812caa0225.tar.gz
gentoo-437eb41205b8f17951caee1c2b26c4812caa0225.tar.bz2
gentoo-437eb41205b8f17951caee1c2b26c4812caa0225.zip
dev-python/django-tastypie: fix broken "doc" dependencies
The "doc" conditional dependencies were, strangely, different from the runtime dependency and pinned specifically on django 1.9 which had to be masked for security reasons. Because of that, we had to mask the "doc" USE flag on the package. In this commit, we remove these strange dependencies and use the same as the runtime deps. Documentation builds fine. Committing as straight-to-stable because documentation simply couldn't be built before that. Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-python/django-tastypie/django-tastypie-0.13.3-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/django-tastypie/django-tastypie-0.13.3-r1.ebuild b/dev-python/django-tastypie/django-tastypie-0.13.3-r1.ebuild
index 366834775c9b..901a7ba4a769 100644
--- a/dev-python/django-tastypie/django-tastypie-0.13.3-r1.ebuild
+++ b/dev-python/django-tastypie/django-tastypie-0.13.3-r1.ebuild
@@ -28,8 +28,10 @@ RDEPEND="${COMMON_DEPEND}
# test: django fails at current version of sci-libs/geos, making tests
# explode immediately
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${COMMON_DEPEND}
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
dev-python/biplist[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
@@ -38,8 +40,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pytz-2013b[${PYTHON_USEDEP}]
!!sci-libs/geos[python] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/django-1.9[${PYTHON_USEDEP}]
- <dev-python/django-1.10[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/mock-1.1.0[${PYTHON_USEDEP}]' python2_7)
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )"