summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-05 15:02:35 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-05 15:32:40 -0500
commit438a6f80a186fdb30eb1a844aebfe5341d4b7a82 (patch)
tree15091b2615191b85f4e2d74145c9d56bd6e6070e
parentdev-db/soci: Revbump for dependency change (diff)
downloadgentoo-438a6f80.tar.gz
gentoo-438a6f80.tar.bz2
gentoo-438a6f80.zip
dev-libs/libhome: Revbump for dependency change
Closes: https://bugs.gentoo.org/665878 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-libs/libhome/files/libhome-0.10.2-Makefile.patch4
-rw-r--r--dev-libs/libhome/libhome-0.10.2-r2.ebuild (renamed from dev-libs/libhome/libhome-0.10.2-r1.ebuild)27
2 files changed, 16 insertions, 15 deletions
diff --git a/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch b/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch
index 54915fd4bb04..371335b0bec8 100644
--- a/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch
+++ b/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.in
-+++ Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
@@ -61,7 +61,7 @@
LIBTOOL=./libtool
diff --git a/dev-libs/libhome/libhome-0.10.2-r1.ebuild b/dev-libs/libhome/libhome-0.10.2-r2.ebuild
index ef3cfe46b6ca..b94cfd3c8377 100644
--- a/dev-libs/libhome/libhome-0.10.2-r1.ebuild
+++ b/dev-libs/libhome/libhome-0.10.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit autotools db-use eutils
+inherit autotools db-use
DESCRIPTION="libhome is a library providing a getpwnam() emulation"
HOMEPAGE="http://pll.sourceforge.net"
@@ -12,20 +12,24 @@ SRC_URI="mirror://sourceforge/pll/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="berkdb ldap mysql pam postgres"
+IUSE="berkdb ldap mysql pam postgres static-libs"
DEPEND="berkdb? ( >=sys-libs/db-4 )
ldap? ( net-nds/openldap )
- mysql? ( virtual/mysql )
+ mysql? ( dev-db/mysql-connector-c:= )
pam? ( virtual/pam )
postgres? ( dev-db/postgresql[server] )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.2-Makefile.patch
+ "${FILESDIR}"/${PN}-0.10.2-ldap_deprecated.patch
+)
+
src_prepare() {
rm -f aclocal.m4
- epatch "${FILESDIR}"/${PN}-0.10.2-Makefile.patch
- epatch "${FILESDIR}"/${PN}-0.10.2-ldap_deprecated.patch
+ default
# bug 225579
sed -i -e 's:\<VERSION\>:__PKG_VERSION:' configure.in
@@ -43,13 +47,10 @@ src_configure() {
$(use_with mysql) \
$(use_with pam) \
$(use_with postgres pgsql) \
- || die "econf failed"
-}
-
-src_compile() {
- emake || die "emake failed"
+ $(use_enable static-libs static)
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ default
+ use static-libs || find "${D}" -name '*.la' -delete
}