summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-04-02 15:14:34 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-04-02 15:14:51 +0200
commit439042e4671fb20457388ddb74e7fb12d526a20a (patch)
tree9cd651e965691120bf19ce2fdbb2f5b0b58d6b49
parentx11-misc/xsnow: drop 3.5.3-r1 (diff)
downloadgentoo-439042e4671fb20457388ddb74e7fb12d526a20a.tar.gz
gentoo-439042e4671fb20457388ddb74e7fb12d526a20a.tar.bz2
gentoo-439042e4671fb20457388ddb74e7fb12d526a20a.zip
x11-misc/xsnow: add 3.7.4
Closes: https://bugs.gentoo.org/902089 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--x11-misc/xsnow/Manifest1
-rw-r--r--x11-misc/xsnow/xsnow-3.7.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/xsnow/Manifest b/x11-misc/xsnow/Manifest
index 64d6ac74097e..247646e8e77a 100644
--- a/x11-misc/xsnow/Manifest
+++ b/x11-misc/xsnow/Manifest
@@ -1,2 +1,3 @@
DIST xsnow-3.3.0.tar.gz 405967 BLAKE2B d2b6d87b781c894c09157ff2f06389d0b1cf401eff735b812ec324560d295195c5afaa3c9c755f569f10f4ff4cd9738dbcc393044dbdebc13454bfeb8e1a9065 SHA512 b2674039ed26c5788a137cf44396b18f07458e926ea0552034d2c78cefaeaffce35ef42f2da386ee48b8b4d8f98960a4a31edfcf737c6d269485785699f9227a
DIST xsnow-3.6.0.tar.gz 495875 BLAKE2B 9ebc87254ce81b7fd051bbc0170faa7198390679a8dbaccdfa3674b1f584ad298fa73506b7eb8ff63fe04f168ebafcd30bc2101510c4e912e029edefe4813c65 SHA512 e2684e6d011a8add8819e16b6b649f8d501525c41a4baa0ef32d90b7603e30910a77093c2d21f52a7adb72f0ba18076f9265557e70dc246b365e0fd2b8ed4ab1
+DIST xsnow-3.7.4.tar.gz 1381177 BLAKE2B 7ebc5bf2c64ddfebf1167fd6ceb29ed52f88273bccc4d8f679d102573bbd55f5da0c3b1c01a3157a4de515d1301451ada24539555c31afd5fc015228c35a0dd4 SHA512 ac58a7ea63126d61a8f01d06422db8f12b31d23ff2edf03967f4a12e146e2d5934a24643d8487e35f6f99d35ffcf188cbaafae49d587e6ffe5019f1476358663
diff --git a/x11-misc/xsnow/xsnow-3.7.4.ebuild b/x11-misc/xsnow/xsnow-3.7.4.ebuild
new file mode 100644
index 000000000000..27ff71302c85
--- /dev/null
+++ b/x11-misc/xsnow/xsnow-3.7.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools xdg
+
+DESCRIPTION="let it snow on your desktop and windows"
+HOMEPAGE="https://www.ratrabbit.nl/ratrabbit/xsnow/"
+SRC_URI="https://www.ratrabbit.nl/downloads/xsnow/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ sci-libs/gsl:=
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXpm
+ x11-libs/libXtst
+ x11-libs/libxkbcommon
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.7-gamesdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # Install xscreensaver hack, which calls xsnow with the correct
+ # arguments. xscreensaver calls all hacks with --root, however xsnow
+ # only understands -root and will exit with an error if an unknown
+ # argument (--root) is provided.
+ exeinto usr/$(get_libdir)/misc/xscreensaver
+ newexe - xsnow <<-EOF
+ #/usr/bin/env bash
+ exec "${EPREFIX}/usr/bin/xsnow" -nomenu -root
+EOF
+}