summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 17:45:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 20:04:53 +0100
commit43999a27e8f85fa299baf8bb4557a91609adc2b5 (patch)
tree1903b3706af972a56addb4ccb3fd62cf41075645
parentdev-python/jupyter-server: Bump to 2.11.0 (diff)
downloadgentoo-43999a27e8f85fa299baf8bb4557a91609adc2b5.tar.gz
gentoo-43999a27e8f85fa299baf8bb4557a91609adc2b5.tar.bz2
gentoo-43999a27e8f85fa299baf8bb4557a91609adc2b5.zip
dev-python/ipykernel: Bump to 6.27.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-6.27.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index 0230e452d8a4..3b61773cf485 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,2 +1,3 @@
DIST ipykernel-6.25.2.tar.gz 156247 BLAKE2B 796ed40dd5ef11dbe8a0bb330aafd1e51e40b1fa5a0b55bdb1a1aff4d89187b3c6b3831f3d44b131f5e8158d6035697f788877a8e682c4c0355da74825ee2200 SHA512 a6f5089cff8c297379ae840b49ad705d23db46aa04030c7a2598031d118b5c0dd64e091de4d66adfd876e8ef45abfcb6bc963c3311dd8e50f4e83236bfc4cfa3
DIST ipykernel-6.26.0.tar.gz 157526 BLAKE2B 8ba5cf820cf03d7735a4dbcb613925b9f9f83d949e065d61f546f3b8ded17accdfdcb4d72718fa644f2233f0397afe8f77437fed1d219710ecac6c9db523e08e SHA512 8199f59ac0147e3b21a07f28d64bf73311ccbf6b48b060979a520ac798a058496e659d08a7b41b1321b4be7092e09fe793d80fb061fc2706b46aa17e93e142f8
+DIST ipykernel-6.27.0.tar.gz 157721 BLAKE2B ea34d02f57f67d720fb744f8bd7fd9a191ec2c104aafca2741eb50b4a28519e609efc465e73dbd2aad5ce1c0e383ea33115f13171deee70825d734a42f38c852 SHA512 13c9c1c2083def67b3fa5e93b03d77a40b14d2505a07386554e03f896e9ca961c54ab6b7d51fbe05bd684f1acf651196a2b0f804ded23461eac5b6500b829c45
diff --git a/dev-python/ipykernel/ipykernel-6.27.0.ebuild b/dev-python/ipykernel/ipykernel-6.27.0.ebuild
new file mode 100644
index 000000000000..5c20d40e3a48
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-6.27.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="
+ https://github.com/ipython/ipykernel/
+ https://pypi.org/project/ipykernel/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/comm-0.1.1[${PYTHON_USEDEP}]
+ !elibc_Darwin? (
+ $(python_gen_cond_dep '
+ >=dev-python/debugpy-1.6.5[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-8[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.12[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-inline-0.1[${PYTHON_USEDEP}]
+ dev-python/nest-asyncio[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-20[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4.0[${PYTHON_USEDEP}]
+"
+# RDEPEND seems specifically needed in BDEPEND, at least jupyter
+# bug #816486
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ipyparallel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ # Use python3 in kernel.json configuration, bug #784764
+ sed -i -e '/python3.[0-9]\+/s//python3/' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/share/jupyter/kernels/python3/kernel.json" || die
+}
+
+src_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_debugger.py::test_attach_debug
+ tests/test_debugger.py::test_breakpoint_in_cell_with_leading_empty_lines
+ tests/test_debugger.py::test_rich_inspect_at_breakpoint
+ tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
+ tests/test_debugger.py::test_set_breakpoints
+ tests/test_debugger.py::test_stop_on_breakpoint
+ tests/test_debugger.py::test_copy_to_globals
+ # hangs?
+ tests/test_eventloop.py::test_tk_loop
+ # doesn't like pyside2?
+ tests/test_eventloop.py::test_qt_enable_gui
+ )
+
+ virtx distutils-r1_src_test
+}