summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-04-21 11:06:34 +0800
committerYixun Lan <dlan@gentoo.org>2022-04-21 11:28:35 +0800
commit43a05f7490fa0a1d8f6660a1bded74cedc0568ae (patch)
tree4c76b3a492ce69f3f6c2dde7ff1f0c44aaefa720
parentapp-emulation/qemu: depend on >=dtc-1.5.1, bump FIRMWARE_ABI_VERSION (diff)
downloadgentoo-43a05f74.tar.gz
gentoo-43a05f74.tar.bz2
gentoo-43a05f74.zip
app-backup/snapper: add 0.10.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-backup/snapper/Manifest1
-rw-r--r--app-backup/snapper/files/snapper-0.10.0-testsuite.patch84
-rw-r--r--app-backup/snapper/snapper-0.10.0.ebuild88
3 files changed, 173 insertions, 0 deletions
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
index caae74396a11..5ba939cd025f 100644
--- a/app-backup/snapper/Manifest
+++ b/app-backup/snapper/Manifest
@@ -1 +1,2 @@
+DIST snapper-0.10.0.tar.gz 404564 BLAKE2B 2dd3f889cf445e06975b5a6f1088d07445510c6905dacecd5b75c0b92c155d399b9b6ed07e466303e4ea3e4b3e6aa72f57b9a34fc2b3aa97c328d886732a375c SHA512 eb0b8568f90907a84dd6f6e135f26cddbafbb8a420f2e4c3ad657d4d782ff35517da93c375d9796dbac1a03983e8b88084280347b51eadf869294dcc080dbfeb
DIST snapper-0.9.1.tar.gz 400387 BLAKE2B fe9d25f573dc99e0eb6c876fa2ebb34140ea8177c72a65af65bd4b6621b81bcab71ee03948696d311444cad4c69d21db70161f67ef3917aea93e39ad54b10444 SHA512 447a024570bbb834adfc789aa5b12b037838fcf50f8d26f87a9a10b250541a589be3b24b01f990625021b8ff5b2eade0f2eda5e992f76113c62bd5e8a27c1293
diff --git a/app-backup/snapper/files/snapper-0.10.0-testsuite.patch b/app-backup/snapper/files/snapper-0.10.0-testsuite.patch
new file mode 100644
index 000000000000..643c98bf1a70
--- /dev/null
+++ b/app-backup/snapper/files/snapper-0.10.0-testsuite.patch
@@ -0,0 +1,84 @@
+diff --git a/configure.ac b/configure.ac
+index 3f5c911..a8c9c95 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -84,6 +84,13 @@ CPPFLAGS="${CPPFLAGS} -DCONF_DIR='\"${SYSCONFIG}\"'"
+
+ PAM_SECURITY=${libdir}/security
+
++AC_ARG_ENABLE([tests], AC_HELP_STRING([--disable-tests],[Disable internal tests support]),
++ [with_tests=$enableval],[with_tests=yes])
++AM_CONDITIONAL(ENABLE_TESTS, [test "x$with_tests" = "xyes"])
++if test "x$with_tests" = "xyes"; then
++ AC_DEFINE(ENABLE_TESTS, 1, [Enable internal tests support])
++fi
++
+ AC_ARG_WITH([pam-security], AC_HELP_STRING([--pam-security], [Use a custom pam security directory (default is $libdir/security)]),
+ [with_pam_security=$withval], [with_pam_security=no])
+ AS_IF([test "x$with_pam_security" != xno], [PAM_SECURITY="${with_pam_security}"])
+diff --git a/testsuite-cmp/Makefile.am b/testsuite-cmp/Makefile.am
+index 81104bf..9c29477 100644
+--- a/testsuite-cmp/Makefile.am
++++ b/testsuite-cmp/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite-cmp
+ #
+
++if ENABLE_TESTS
+ AM_CPPFLAGS = -I$(top_srcdir)
+ AM_LDFLAGS = -lboost_system
+
+@@ -15,3 +16,4 @@ cmp_SOURCES = cmp.cc
+
+ EXTRA_DIST = $(noinst_SCRIPTS)
+
++endif
+diff --git a/testsuite-real/Makefile.am b/testsuite-real/Makefile.am
+index ceb0862..9a72775 100644
+--- a/testsuite-real/Makefile.am
++++ b/testsuite-real/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite-real
+ #
+
++if ENABLE_TESTS
+ CXXFLAGS += -std=gnu++11
+
+ AM_CPPFLAGS = -I$(top_srcdir)
+@@ -53,3 +54,4 @@ ug_tests_SOURCES = ug-tests.cc
+
+ EXTRA_DIST = $(test_DATA) $(test_SCRIPTS)
+
++endif
+diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
+index ccb84d3..409e265 100644
+--- a/testsuite/Makefile.am
++++ b/testsuite/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite
+ #
+
++if ENABLE_TESTS
+ AM_CPPFLAGS = -I$(top_srcdir) $(DBUS_CFLAGS)
+
+ LDADD = ../snapper/libsnapper.la ../dbus/libdbus.la -lboost_unit_test_framework
+@@ -48,3 +49,4 @@ lvm_utils_test_LDADD = -lboost_unit_test_framework ../snapper/libsnapper.la
+ range_test_LDADD = -lboost_unit_test_framework ../client/utils/libutils.la
+
+ limit_test_LDADD = -lboost_unit_test_framework ../client/utils/libutils.la
++endif
+diff --git a/zypp-plugin/testsuite/Makefile.am b/zypp-plugin/testsuite/Makefile.am
+index 7b52e13..71cb545 100644
+--- a/zypp-plugin/testsuite/Makefile.am
++++ b/zypp-plugin/testsuite/Makefile.am
+@@ -1,3 +1,5 @@
++
++if ENABLE_TESTS
+ if HAVE_ZYPP
+ TEST_LOG_DRIVER = $(SHELL) tap-driver.sh
+
+@@ -12,3 +14,4 @@ TESTS = $(check_SCRIPTS)
+
+ EXTRA_DIST = $(check_SCRIPTS) $(noinst_SCRIPTS) $(noinst_DATA) tap-driver.sh
+ endif
++endif
diff --git a/app-backup/snapper/snapper-0.10.0.ebuild b/app-backup/snapper/snapper-0.10.0.ebuild
new file mode 100644
index 000000000000..11fe4ff862dd
--- /dev/null
+++ b/app-backup/snapper/snapper-0.10.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
+HOMEPAGE="http://snapper.io/"
+SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc lvm pam test systemd xattr"
+RESTRICT="test"
+
+RDEPEND="dev-libs/boost:=[threads(+)]
+ dev-libs/json-c:=
+ dev-libs/libxml2
+ dev-libs/icu:=
+ sys-apps/acl
+ sys-apps/dbus
+ sys-apps/util-linux
+ >=sys-fs/btrfs-progs-3.17.1
+ sys-libs/zlib
+ virtual/libintl
+ lvm? ( sys-fs/lvm2 )
+ pam? ( sys-libs/pam )
+ xattr? ( sys-apps/attr )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/cron-confd.patch
+ "${FILESDIR}"/${P}-testsuite.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
+ -i data/Makefile.* \
+ || die "Failed to fix systemd services and timers installation path"
+ eautoreconf
+}
+
+src_configure() {
+ # ext4 code does not work anymore
+ # snapper does not build without btrfs
+ local myeconfargs=(
+ --disable-silent-rules
+ --with-conf="/etc/conf.d"
+ --enable-zypp
+ --enable-rollback
+ --enable-btrfs-quota
+ --disable-ext4
+ --enable-btrfs
+ $(use_enable doc)
+ $(use_enable lvm)
+ $(use_enable pam)
+ $(use_enable test tests)
+ $(use_enable systemd)
+ $(use_enable xattr xattrs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Existing configuration file required to function
+ keepdir /etc/snapper/configs
+ newconfd data/sysconfig.snapper snapper
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "In order to use Snapper, you need to set up"
+ elog "at least one config first. To do this, run:"
+ elog "snapper create-config <subvolume>"
+ elog "For more information, see man (8) snapper or"
+ elog "http://snapper.io/documentation.html"
+}