summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-18 03:06:05 +0100
committerSam James <sam@gentoo.org>2023-08-18 10:22:32 +0100
commit43a24d68531ab4ca9ad83d686a620cd2937dbf4f (patch)
tree303143469ea575be74629facdfe0f3c0377d8cd4
parentsys-devel/clang-common: update for newer libcxx (diff)
downloadgentoo-43a24d68531ab4ca9ad83d686a620cd2937dbf4f.tar.gz
gentoo-43a24d68531ab4ca9ad83d686a620cd2937dbf4f.tar.bz2
gentoo-43a24d68531ab4ca9ad83d686a620cd2937dbf4f.zip
sys-devel/clang-common: only add default configs (e.g. -fPIE) for native tools
We don't want to add our configs to 'clang', 'clang++', etc because that might be used for crosscompilation. Use the prefixed CHOST versions instead. [I suspect I didn't do this before because the old config logic, before we improved it upstream, didn't have the fallback behaviour for clang->${CHOST}-clang or similar.] Closes: https://bugs.gentoo.org/901247 Closes: https://bugs.gentoo.org/912237 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0.9999.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0.9999.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230810-r1.ebuild (renamed from sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild)5
5 files changed, 20 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg
diff --git a/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild b/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg
diff --git a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230810-r1.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230810-r1.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg