summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-22 09:53:40 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-22 10:03:07 +0200
commit43ad9c478c9f122417c145b7442f30d9ff593fe3 (patch)
treee7fc3d7f7ba9f5ed0c38873a76ca37cde2fb5c18
parentdev-haskell/chimera: treeclean (diff)
downloadgentoo-43ad9c478c9f122417c145b7442f30d9ff593fe3.tar.gz
gentoo-43ad9c478c9f122417c145b7442f30d9ff593fe3.tar.bz2
gentoo-43ad9c478c9f122417c145b7442f30d9ff593fe3.zip
dev-haskell/chasingbottoms: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-haskell/chasingbottoms/Manifest1
-rw-r--r--dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild39
-rw-r--r--dev-haskell/chasingbottoms/metadata.xml102
-rw-r--r--profiles/package.mask1
4 files changed, 0 insertions, 143 deletions
diff --git a/dev-haskell/chasingbottoms/Manifest b/dev-haskell/chasingbottoms/Manifest
deleted file mode 100644
index c3c63dcea7db..000000000000
--- a/dev-haskell/chasingbottoms/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ChasingBottoms-1.3.1.9.tar.gz 31942 BLAKE2B b94cb27358a1af57e2617ac5b967826d1f20709817622e9c8619fdc8270eb0fc12ea8630f06f012d657f03bded69231ba86039bb07d2ffd4ed3b52ae95c0bc28 SHA512 15b05c3080e7e5960d9f84d4c3a3941a08a8f15a4c8241f7fee11f24054e09092925093f88bdd7ac38eedc57a02fa76c468e61c5ad08cb0c599a2a01bbe6b88b
diff --git a/dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild b/dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild
deleted file mode 100644
index 6b7d544696f8..000000000000
--- a/dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.4.9999
-#hackport: flags: -build-tests
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-MY_PN="ChasingBottoms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="For testing partial and infinite values"
-HOMEPAGE="https://hackage.haskell.org/package/ChasingBottoms"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/quickcheck-2.10:2=[profile?] <dev-haskell/quickcheck-2.15:2=[profile?]
- >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
- >=dev-haskell/syb-0.1.0.2:=[profile?] <dev-haskell/syb-0.8:=[profile?]
- >=dev-lang/ghc-7.6.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.16.0
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-build-tests
-}
diff --git a/dev-haskell/chasingbottoms/metadata.xml b/dev-haskell/chasingbottoms/metadata.xml
deleted file mode 100644
index 697509ead8f5..000000000000
--- a/dev-haskell/chasingbottoms/metadata.xml
+++ /dev/null
@@ -1,102 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Do you ever feel the need to test code involving bottoms (e.g. calls to
- the @error@ function), or code involving infinite values? Then this
- library could be useful for you.
-
- It is usually easy to get a grip on bottoms by showing a value and
- waiting to see how much gets printed before the first exception is
- encountered. However, that quickly gets tiresome and is hard to automate
- using e.g. QuickCheck
- (&lt;http://www.cse.chalmers.se/~rjmh/QuickCheck/&gt;). With this library you
- can do the tests as simply as the following examples show.
-
- Testing explicitly for bottoms:
-
- [@&gt; isBottom (head [\])@] @True@
-
- [@&gt; isBottom bottom@] @True@
-
- [@&gt; isBottom (\\_ -&gt; bottom)@] @False@
-
- [@&gt; isBottom (bottom, bottom)@] @False@
-
- Comparing finite, partial values:
-
- [@&gt; ((bottom, 3) :: (Bool, Int)) ==! (bottom, 2+5-4)@] @True@
-
- [@&gt; ((bottom, bottom) :: (Bool, Int)) &lt;! (bottom, 8)@] @True@
-
- Showing partial and infinite values (@\\\/!@ is join and @\/\\!@ is meet):
-
- [@&gt; approxShow 4 $ (True, bottom) \\\/! (bottom, \'b\')@] @\"Just (True, \'b\')\"@
-
- [@&gt; approxShow 4 $ (True, bottom) \/\\! (bottom, \'b\')@] @\"(_|_, _|_)\"@
-
- [@&gt; approxShow 4 $ ([1..\] :: [Int\])@] @\"[1, 2, 3, _\"@
-
- [@&gt; approxShow 4 $ (cycle [bottom\] :: [Bool\])@] @\"[_|_, _|_, _|_, _\"@
-
- Approximately comparing infinite, partial values:
-
- [@&gt; approx 100 [2,4..\] ==! approx 100 (filter even [1..\] :: [Int\])@] @True@
-
- [@&gt; approx 100 [2,4..\] \/=! approx 100 (filter even [bottom..\] :: [Int\])@] @True@
-
- The code above relies on the fact that @bottom@, just as @error
- \"...\"@, @undefined@ and pattern match failures, yield
- exceptions. Sometimes we are dealing with properly non-terminating
- computations, such as the following example, and then it can be nice to
- be able to apply a time-out:
-
- [@&gt; timeOut' 1 (reverse [1..5\])@] @Value [5,4,3,2,1]@
-
- [@&gt; timeOut' 1 (reverse [1..\])@] @NonTermination@
-
- The time-out functionality can be used to treat \"slow\" computations as
- bottoms:
-
- [@&gt; let tweak = Tweak &amp;#x7b; approxDepth = Just 5, timeOutLimit = Just 2 &amp;#x7d;@]
-
- [@&gt; semanticEq tweak (reverse [1..\], [1..\]) (bottom :: [Int\], [1..\] :: [Int\])@] @True@
-
- [@&gt; let tweak = noTweak &amp;#x7b; timeOutLimit = Just 2 &amp;#x7d;@]
-
- [@&gt; semanticJoin tweak (reverse [1..\], True) ([\] :: [Int\], bottom)@] @Just ([],True)@
-
- This can of course be dangerous:
-
- [@&gt; let tweak = noTweak &amp;#x7b; timeOutLimit = Just 0 &amp;#x7d;@]
-
- [@&gt; semanticEq tweak (reverse [1..100000000\]) (bottom :: [Integer\])@] @True@
-
- Timeouts can also be applied to @IO@ computations:
-
- [@&gt; let primes = unfoldr (\\(x:xs) -&gt; Just (x, filter ((\/= 0) . (\`mod\` x)) xs)) [2..\]@]
-
- [@&gt; timeOutMicro 100 (print $ filter ((== 1) . (\`mod\` 83)) primes)@] @[167,499,9NonTermination@
-
- [@&gt; timeOutMicro 100 (print $ take 6 $ filter ((== 1) . (\`mod\` 83)) primes)@] @[167,499,997,1163,1993NonTermination@
-
- [@&gt; timeOutMicro 100 (print $ take 6 $ filter ((== 1) . (\`mod\` 83)) primes)@] @[167,499,997,1163,1993,2657]@
-
- [@ @] @Value ()@
-
- For the underlying theory and a larger example involving use of
- QuickCheck, see the article \"Chasing Bottoms, A Case Study in Program
- Verification in the Presence of Partial and Infinite Values\"
- (&lt;http://www.cse.chalmers.se/~nad/publications/danielsson-jansson-mpc2004.html&gt;).
-
- The code has been tested using GHC. Most parts can probably be
- ported to other Haskell compilers, but this would require some work.
- The @TimeOut@ functions require preemptive scheduling, and most of
- the rest requires @Data.Generics@; @isBottom@ only requires
- exceptions, though.
- </longdescription>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 0eb1853419c2..bd9a31d64dcd 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -365,7 +365,6 @@ dev-haskell/bzlib
dev-haskell/cairo
dev-haskell/cereal-vector
dev-haskell/cgi
-dev-haskell/chasingbottoms
# Hans de Graaff <graaff@gentoo.org> (2022-07-16)
# No longer supported upstream. Use a newer ruby version instead.