summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-28 13:30:45 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-28 13:32:15 +0200
commit43b0e8979eda080fba1233b48fcb657e3d483ac2 (patch)
tree20493131fe28e5d899dfcf4c013b6eaa68ce947c
parentdev-python/uvicorn: add 0.17.1 (diff)
downloadgentoo-43b0e897.tar.gz
gentoo-43b0e897.tar.bz2
gentoo-43b0e897.zip
dev-python/ruamel-std-pathlib: add 0.9.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/ruamel-std-pathlib/Manifest1
-rw-r--r--dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.9.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ruamel-std-pathlib/Manifest b/dev-python/ruamel-std-pathlib/Manifest
index 5fbe0850eb93..50e7848dc418 100644
--- a/dev-python/ruamel-std-pathlib/Manifest
+++ b/dev-python/ruamel-std-pathlib/Manifest
@@ -1,2 +1,3 @@
DIST ruamel-std-pathlib-0.8.0.tar.xz 19068 BLAKE2B e1709bf5af17a843a7f5aec8009c4ec337cd1a4a526315e8834924909613eb5cc50c2ae1a1acc74c97a876fa347767dce627f2dba1fb874032f0989f7ee6599e SHA512 eecbb43e3867d8ccb166a0d528b3d7cfc04ed6f2df5e2048ccec4d7fd36117ac4a3984d4143025f6b7fd51867de879fe02e5dcbc4b275fd40cab1609bcf69536
DIST ruamel-std-pathlib-0.9.0.tar.xz 19340 BLAKE2B 1ab661f3dc4cb75eed20426256f5c14fd9c3b44894c343dd55bd53dbb811eb90ea90ff8c1056b0eb4a5d186521786e22e42f8db48d8dde42885c72f34f8e3782 SHA512 ba551b3b07db87e46e059ddf17b0768283e8da49c7ea5bb252fba6ca611bb69d160fd6a3d3557eac0606b8aece5ee21aced2889609d95cfeb6f59473d72a261e
+DIST ruamel-std-pathlib-0.9.1.tar.xz 19408 BLAKE2B 26c5dbddec337fb5fac6992206d49ecaabf743f2b6d9836c524626b77ca772e8e97e660f8bb22fd4d6e572705ef7d5cf6a012cede315a1662d8786be4ad8eca8 SHA512 d577731c504719b650a718c98979d28442f48ca1526b653f8faeadc4720f5cff09f0554fe5b8eb1cd65c7d3106f0b9e0a4d11f1f416458df187c51f707d137b6
diff --git a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.9.1.ebuild b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.9.1.ebuild
new file mode 100644
index 000000000000..0a4ef44ff9f0
--- /dev/null
+++ b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_P="${PN//-/.}-${PV}"
+
+DESCRIPTION="Ruamel enhancements to pathlib and pathlib2"
+HOMEPAGE="https://pypi.org/project/ruamel.std.pathlib/ https://sourceforge.net/p/ruamel-std-pathlib/"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="dev-python/namespace-ruamel[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}