summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Qian <i@bitbili.net>2023-12-12 20:30:13 +0800
committerYixun Lan <dlan@gentoo.org>2023-12-12 23:30:57 +0000
commit43c65cbdc49afd7c14a5c540e725421730f54cc6 (patch)
tree128b4d3bfc6cd0d32c540909fe65ba2d8f2f8101
parentnet-im/slack: drop 4.35.126 (diff)
downloadgentoo-43c65cbdc49afd7c14a5c540e725421730f54cc6.tar.gz
gentoo-43c65cbdc49afd7c14a5c540e725421730f54cc6.tar.bz2
gentoo-43c65cbdc49afd7c14a5c540e725421730f54cc6.zip
www-apps/gitea: add 1.21.2
Closes: https://github.com/gentoo/gentoo/pull/34250 Signed-off-by: Ryan Qian <i@bitbili.net> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.21.2.ebuild145
2 files changed, 146 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index d42716bbd36c..c492a3236fee 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,2 +1,3 @@
DIST gitea-1.20.6.tar.gz 50473256 BLAKE2B 0b26e38815dc1bf16c6f50c0b4cd7e6c3c3e0900056beda6177cb7fd1df1378e89a6ca47228f3fef2f6176eb5054d1bfb999ba1a1314a5915dbbff62f0f1365a SHA512 fb0a979bdaaec25512f70cbcb1907d5e649eff2d0795a6bb5fe9e582ada1f132ca649dd594ccd24051fa6e2e0fd3b94effc66475ab2f9faeb03cebd4c657336a
DIST gitea-1.21.1.tar.gz 53759159 BLAKE2B 46c9b1143681304268d6617a0b4eadbf3ff08c566256c3c73c2a334fc4f93a2d7ae1c33566af962b4e376dc3b7e44c0687640ce5f68db0e679ed2507f81e22c4 SHA512 8a05cfd83317b4bcdb99cac175517a3c2b39bef0d7f7321cf00fc83965d10818b2fa14396f341b7b0a7b3e9e38548333b2e1cbfbf6fe6ed486558160b2c75eb0
+DIST gitea-1.21.2.tar.gz 53795805 BLAKE2B ee85aae28325df59aa7fefcda5e3ec4216f79e115972fcbea543b189c6f8fe2bb2f7d23f27cd2418c7f50e474177398e4cd925474ca5d68fe3bab64a2cf785b7 SHA512 809254dfe420fb97697855d2aa815344b56d316edaec140598526fc7728275ca9a10179093b8d036cce0947684234a0aa2fa7febdd1bbdf7f831a249cc16ba4a
diff --git a/www-apps/gitea/gitea-1.21.2.ebuild b/www-apps/gitea/gitea-1.21.2.ebuild
new file mode 100644
index 000000000000..15ca9f045d07
--- /dev/null
+++ b/www-apps/gitea/gitea-1.21.2.ebuild
@@ -0,0 +1,145 @@
+# Copyright 2016-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module tmpfiles systemd flag-o-matic user-info
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.com https://github.com/go-gitea/gitea"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/go-gitea/gitea.git"
+else
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+S="${WORKDIR}/${PN}-src-${PV}"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct pam sqlite pie"
+
+DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+BDEPEND=">=dev-lang/go-1.21:="
+
+DOCS=(
+ custom/conf/app.example.ini CHANGELOG.md CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ -m 711 cap_net_bind_service+ep usr/bin/gitea
+)
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ sed -i -e "s#^MODE = console#MODE = file#" custom/conf/app.example.ini || die
+}
+
+src_configure() {
+ # bug 832756 - PIE build issues
+ filter-flags -fPIE
+ filter-ldflags -fPIE -pie
+}
+
+src_compile() {
+ local gitea_tags
+ local -a gitea_settings makeenv
+
+ # The space-separated list of the -tags flag is deprecated, please
+ # always use the comma-separated list in the future.
+ gitea_tags="bindata"
+ gitea_tags+="$(usex pam ',pam' '')"
+ gitea_tags+="$(usex sqlite ',sqlite,sqlite_unlock_notify' '')"
+
+ gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+
+ makeenv=(
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
+ TAGS="${gitea_tags}"
+ )
+
+ if [[ ${PV} != *9999 ]]; then
+ # Use variable STORED_VERSION_FILE (the "${S}/VERSION" file) to set version,
+ # and prevent executing git command when it's not a live version.
+ makeenv+=( GITHUB_REF_NAME="" )
+ fi
+
+ if use pie ; then
+ # Please check the supported platforms when a new keyword request opened,
+ # refer to file: 'go/src/internal/platform/supported.go'.
+ # When PIE buildmode is not supported by internal linker, the external
+ # linker will be used automatically, refer to:
+ # https://github.com/golang/go/blob/ed817f1c4055a559a94afffecbb91c78e4f39942/src/cmd/link/internal/ld/config.go#L149
+ makeenv+=( EXTRA_GOFLAGS="-buildmode=pie" )
+ fi
+
+ env "${makeenv[@]}" emake backend
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r4 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.example.ini app.ini
+ if use acct; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ # It is not guaranteed that the git user and group always exist (due to the acct USE Flag),
+ # but for convenience, the tmpfile uses the git user and group by default.
+ # To avoid installation errors, a condition needs to be added here:
+ # if there is no git user or group, the installation of tmpfile will be skipped
+ # and the user will be notified to handle it by themselves.
+ if egetent passwd git &>/dev/null && \
+ egetent group git &>/dev/null; then
+ tmpfiles_process gitea.conf
+ else
+ eerror "Unable to install the tmpfile for gitea due to the git user or group is missing,"
+ eerror "please install tmpfile manually or rebuild this package with USE flag 'acct'."
+ eerror "You can simply copy the default tmpfile from '/usr/lib/tmpfiles.d/gitea.conf'"
+ eerror "to higher priority path '/etc/tmpfiles.d/gitea.conf', and correct it with"
+ eerror "the right User and Group value (see tmpfiles.d(5) for details), then execute:"
+ eerror " # systemd-tmpfiles --create /etc/tmpfiles.d/gitea.conf"
+ eerror "to install it."
+ fi
+
+ ewarn "Since 1.21.0:"
+ ewarn " 1. The built-in SSH server will now only accept SSH user"
+ ewarn " certificates, not server certificates. This behaviour matches OpenSSH."
+ ewarn " 2. The options of the subcommand must follow the subcommand now."
+ ewarn " 3. Remove 'CHARSET' config option for MySQL, always use 'utf8mb4'."
+ ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.21.0>."
+}