summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-06-09 17:49:18 +0100
committerMatthew Smith <matthew@gentoo.org>2023-06-09 17:49:36 +0100
commit43f654a060813a88209ab9998291b3701eacf86e (patch)
tree64ea81ca4d25befec8e763ba989b1d6e90f83199
parentapp-laptop/hdapsd: drop 20141203-r2 (diff)
downloadgentoo-43f654a060813a88209ab9998291b3701eacf86e.tar.gz
gentoo-43f654a060813a88209ab9998291b3701eacf86e.tar.bz2
gentoo-43f654a060813a88209ab9998291b3701eacf86e.zip
media-gfx/renderdoc: add 1.27
Bug: https://bugs.gentoo.org/908031 Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--media-gfx/renderdoc/Manifest2
-rw-r--r--media-gfx/renderdoc/files/renderdoc-1.27-env-home.patch15
-rw-r--r--media-gfx/renderdoc/renderdoc-1.27.ebuild202
3 files changed, 219 insertions, 0 deletions
diff --git a/media-gfx/renderdoc/Manifest b/media-gfx/renderdoc/Manifest
index 5978148372fd..4da598b1b2ec 100644
--- a/media-gfx/renderdoc/Manifest
+++ b/media-gfx/renderdoc/Manifest
@@ -1,3 +1,5 @@
DIST renderdoc-1.24.tar.gz 46998687 BLAKE2B 34316e81da94eeeb0aff2291563e9bf5c46089746f7dc53f8def2b047d0d377e5c26edd8fee23ff97d77037bcfc8468b7f27f2c82c7f6e80f20cd5278b026d75 SHA512 07cc35800c13893bf1b8f8635d5a819f546e458be6a8111d1b40d54e25977c0b88d7c7bc6a89a813dfa353e0fe0a84a334d3796e04c327bf2f42c65a172f9027
DIST renderdoc-1.24.tar.gz.asc 833 BLAKE2B 0649f4437c57fee9cd69946cff3be0b2b156656fe648b56504ff241dbd43d37d4f3d6a89ea17bd006a7d4778f3d901e25756c069baeb3d55283d9046d19b3cb0 SHA512 fad7ffd3a9538d26b38a9a32a22021063cf9b457cedecb1e40cb7cf7a55e86c290ed1776877612af02205b0f8d35f5331f05e7b2fcdfc00469be21831b62939f
+DIST renderdoc-1.27.tar.gz 47445907 BLAKE2B 58be926cb1282fe5bb2ba195cf71fabd9a5fb5562b5d51a600a98818c8f8bbbd576d8e9c331d3f107cb5db427cd35d242fd3f2f28385a47817fc805f26c47bb4 SHA512 1a6fb0d1942ec403ae1393d6121727aebe6b1eef42e795b03c0e0281bd9ca52fa30b28889a9fe80186a41a1dfbc79f38789b47296bc9b5ba185a19bddd47006f
+DIST renderdoc-1.27.tar.gz.asc 833 BLAKE2B fdfbd1ce367e9757e080e1263651444cd4001fe3d8580672a476923e2cf56b030b568c90566f258b1fd485c15c9d6c5a0b91cfb2c72c831677aa088acb9d4c15 SHA512 a74517747bf19a16d8db241a795e16d1213c745d3ff29236844433937202c91da1e580daac6ec7a54322b215163b0ebf492bef9b77eb603720503e4d3a4849df
DIST swig-renderdoc-7.tar.gz 4006241 BLAKE2B 619f41239f4aef496264d61f44ae042cf80d3ff28491d452cf11ad07e898554c4a32df6119ee0e8e3de36e6bee61855358cd968ad01c9281976e24e9a6cac839 SHA512 5285a65924c069cfb9f73104ad8a95251badac4001293a1757b97ebead5953730c03289159741f82da4c5afe4f61f7c826b105eaf82df044ed2fa21810242c86
diff --git a/media-gfx/renderdoc/files/renderdoc-1.27-env-home.patch b/media-gfx/renderdoc/files/renderdoc-1.27-env-home.patch
new file mode 100644
index 000000000000..09510318c5a5
--- /dev/null
+++ b/media-gfx/renderdoc/files/renderdoc-1.27-env-home.patch
@@ -0,0 +1,15 @@
+--- a/renderdoc/os/posix/linux/linux_stringio.cpp
++++ b/renderdoc/os/posix/linux/linux_stringio.cpp
+@@ -595,11 +595,7 @@ rdcstr GetTempRootPath()
+
+ rdcstr GetAppFolderFilename(const rdcstr &filename)
+ {
+- passwd *pw = getpwuid(getuid());
+- rdcstr homedir = pw ? pw->pw_dir : "";
+-
+- if(homedir.empty())
+- homedir = Process::GetEnvVariable("HOME");
++ rdcstr homedir = Process::GetEnvVariable("HOME");
+
+ if(homedir.empty())
+ {
diff --git a/media-gfx/renderdoc/renderdoc-1.27.ebuild b/media-gfx/renderdoc/renderdoc-1.27.ebuild
new file mode 100644
index 000000000000..ffd0e8f0e5c4
--- /dev/null
+++ b/media-gfx/renderdoc/renderdoc-1.27.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# The swig fork is required for compatibility with both provided and
+# 3rd-party Python scripts. Required patch was sent to upstream in
+# 2014: https://github.com/swig/swig/pull/251
+MY_SWIG_VER=7
+MY_SWIG=swig-${PN}-${MY_SWIG_VER}
+
+AUTOTOOLS_AUTO_DEPEND="no"
+DOCS_BUILDER="sphinx"
+DOCS_DIR="docs"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools cmake flag-o-matic optfeature python-single-r1 docs qmake-utils verify-sig xdg
+
+DESCRIPTION="A stand-alone graphics debugging tool"
+HOMEPAGE="https://renderdoc.org https://github.com/baldurk/renderdoc"
+SRC_URI="
+ https://github.com/baldurk/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ qt5? ( https://github.com/baldurk/swig/archive/${PN}-modified-${MY_SWIG_VER}.tar.gz -> ${MY_SWIG}.tar.gz )
+ verify-sig? ( https://github.com/baldurk/renderdoc/releases/download/v${PV}/v${PV}.tar.gz.asc -> ${P}.tar.gz.asc )
+"
+
+# renderdoc: MIT
+# + cmdline: BSD (not compatible with upstream lib)
+# + farm fresh icons: CC-BY-3.0
+# + half: MIT (not compatible with system dev-libs/half)
+# + include-bin ZLIB (upstream doesn't exist anymore, maintained in tree)
+# + md5: public-domain
+# + plthook: BSD-2
+# + pugixml: MIT
+# + radeon gpu analyzer: MIT
+# + source code pro: OFL-1.1
+# + stb: public-domain
+# + tinyfiledialogs: ZLIB
+# + docs? ( sphinx.paramlinks: MIT )
+# swig: GPL-3+ BSD BSD-2
+LICENSE="BSD BSD-2 CC-BY-3.0 GPL-3+ MIT OFL-1.1 public-domain ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pyside2 qt5"
+REQUIRED_USE="doc? ( qt5 ) pyside2? ( qt5 ) qt5? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ app-arch/lz4:=
+ app-arch/zstd:=
+ dev-libs/miniz:=
+ >=dev-util/glslang-1.3.231:=
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-keysyms
+ virtual/opengl
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ ')
+ )
+ qt5? (
+ ${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ )
+"
+DEPEND="${RDEPEND}"
+# qtcore provides qmake, which is required to build the qrenderdoc gui.
+BDEPEND="
+ x11-base/xorg-proto
+ virtual/pkgconfig
+ qt5? (
+ ${AUTOTOOLS_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libpcre
+ dev-qt/qtcore:5
+ sys-devel/bison
+ )
+ verify-sig? ( sec-keys/openpgp-keys-baldurkarlsson )
+"
+
+PATCHES=(
+ # The analytics seem very reasonable, and even without this patch
+ # they are NOT sent before the user accepts. But default the
+ # selection to off, just in case.
+ "${FILESDIR}"/${PN}-1.18-analytics-off.patch
+
+ # Only search for PySide2 if pyside2 USE flag is set.
+ # Bug #833627
+ "${FILESDIR}"/${PN}-1.18-conditional-pyside.patch
+
+ # Pass CXXFLAGS and LDFLAGS through to qmake when qrenderdoc is
+ # built.
+ "${FILESDIR}"/${PN}-1.18-system-flags.patch
+
+ # Needed to prevent sandbox violations during build.
+ "${FILESDIR}"/${PN}-1.27-env-home.patch
+
+ "${FILESDIR}"/${PN}-1.22-r1-system-glslang.patch
+ "${FILESDIR}"/${PN}-1.18-system-compress.patch
+)
+
+DOCS=( util/LINUX_DIST_README )
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/baldurkarlsson.gpg
+
+pkg_setup() {
+ use qt5 && python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.asc}
+ fi
+
+ # Do not unpack the swig sources here. CMake will do that if
+ # required.
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Ensure that we use the system glslang headers instead of the
+ # vendored copy.
+ rm -r renderdoc/3rdparty/glslang || die 'rm vendored glslang failed'
+
+ # Remove the calls to install the documentation files. Instead,
+ # install them with einstalldocs.
+ sed -i '/share\/doc\/renderdoc/d' \
+ "${S}"/CMakeLists.txt "${S}"/qrenderdoc/CMakeLists.txt \
+ || die 'sed remove doc install failed'
+
+ # Assumes that the build directory is "${S}"/build, which it is not.
+ sed -i "s|../build/lib|${BUILD_DIR}/lib|" \
+ "${S}"/docs/conf.py \
+ || die 'sed patch doc sys.path failed'
+
+ # Bug #836235
+ sed -i '/#include <stdarg/i #include <time.h>' \
+ "${S}"/renderdoc/os/os_specific.h \
+ || die 'sed include time.h failed'
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # Build system does not know that this is a tagged release, as
+ # we just have the tarball and not the git repository.
+ -DBUILD_VERSION_STABLE=ON
+
+ -DENABLE_EGL=ON
+ -DENABLE_GL=ON
+ -DENABLE_GLES=ON
+ -DENABLE_PYRENDERDOC=$(usex qt5)
+ -DENABLE_QRENDERDOC=$(usex qt5)
+ -DENABLE_VULKAN=ON
+
+ # Upstream says that this option is unsupported and should not
+ # be used yet.
+ -DENABLE_WAYLAND=OFF
+
+ -DENABLE_XCB=ON
+ -DENABLE_XLIB=ON
+
+ # Path to glslang*.cmake.
+ -DGLSLANG_TARGET_DIR="${ESYSROOT}"/usr/$(get_libdir)/cmake
+
+ # renderdoc_capture.json is installed here
+ -DVULKAN_LAYER_FOLDER="${EPREFIX}"/etc/vulkan/implicit_layer.d
+ )
+
+ use qt5 && mycmakeargs+=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DRENDERDOC_SWIG_PACKAGE="${DISTDIR}"/${MY_SWIG}.tar.gz
+
+ # Needed after qtchooser removal, bug #836474.
+ -DQMAKE_QT5_COMMAND="$(qt5_get_bindir)"/qmake
+
+ -DQRENDERDOC_ENABLE_PYSIDE2=$(usex pyside2)
+ )
+
+ use pyside2 && mycmakeargs+=( -DPYTHON_CONFIG_SUFFIX=-${EPYTHON} )
+
+ # Lots of type mismatch issues.
+ filter-lto
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ docs_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "android remote contexts" dev-util/android-tools
+ optfeature "vulkan contexts" media-libs/vulkan-loader
+}