summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-04 20:32:08 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-04 21:01:52 +0200
commit43ff8d7a14176e0d5d26b36b6db58356f8a3c663 (patch)
tree64a59afefc3941e5ee329cc3335d1cc92cd88e27
parentapp-emacs/treesit-auto: bump to 1.0.5 (diff)
downloadgentoo-43ff8d7a14176e0d5d26b36b6db58356f8a3c663.tar.gz
gentoo-43ff8d7a14176e0d5d26b36b6db58356f8a3c663.tar.bz2
gentoo-43ff8d7a14176e0d5d26b36b6db58356f8a3c663.zip
dev-lang/typescript: bump to 5.4.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-5.4.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index 15ecc0840a03..0355629c64b5 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1,3 +1,4 @@
DIST typescript-5.3.3.tgz 5761919 BLAKE2B 629d2d97a9d57f63cd693a6d77cc385058778c4e4de6002f5e2646c64d1b8ff80386290435b2c838f647bc76f626e4dfd9613e1237d53fa5e4b98f503fbdf9ea SHA512 a5759cadac4cd2ec404beb4dd001bf045d93caa9873b4d78674ef452c27ea45bd8b914aaf0a1fc0e65a99db5ded2910f0c75d957715c01b2648a3279a0d1275b
DIST typescript-5.4.2.tgz 5824544 BLAKE2B a22ecc8a17be22da10263746537d5ce0a0af359866773d6d4d081332a82436c734628d0d89134db63f46fae57f62f6e674f420cea2fff902c1be1a25307b03d8 SHA512 fb6fe0d0576cd444653fa26c6a44100d78d975930cfabaa96a61592442a1e24c13227de20e480ab5bcb409e35de404cd678472d5ac75e53331d16d95fa68a2cd
DIST typescript-5.4.3.tgz 5824407 BLAKE2B c985361a7248f87437bd3df1ce7a66cb6c409b91718fd874f4a51cbff91d7b1bcf91034d1bcfbd3e469e168c4e2571892b28ac74edcdd04fc12c3391925dfb49 SHA512 2ab3dddcf29a08bafbf0c6a5822c099c0db9366f070267703779985186601bfc22cc8a3d11a8a7355408f7fc836afb5515137687793cb9fdc62c7ba10cc8041e
+DIST typescript-5.4.4.tgz 5825725 BLAKE2B 98ebd2f2c3472b7944009f672d647d34540b3cb331fb02d41069df572dc10a0f19c08aee7a12c0536e6d3895502e4a8c11b8ff0c1dcb2d58e0398795f2ce50fe SHA512 74613656ff1ca55bf0dbcbfc1c23eac9bd3c1336c1511c43a6e849bd3aeeb128547c69e11c169f0ec2dd4b5121871c8be8125013ed9c4f77433c0bfe310ea82f
diff --git a/dev-lang/typescript/typescript-5.4.4.ebuild b/dev-lang/typescript/typescript-5.4.4.ebuild
new file mode 100644
index 000000000000..2be080b52222
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.4.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}