summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-28 09:31:17 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-28 09:31:28 +0200
commit44142fc80056385353aab409cb9a2c56e131bff7 (patch)
tree5966581c6eda22ca2d175233426fb670ae73b138
parentx11-misc/xystray: Fix the Makefile patch to support gcc-5 (diff)
downloadgentoo-44142fc8.tar.gz
gentoo-44142fc8.tar.bz2
gentoo-44142fc8.zip
media-sound/kradio: EAPI 6, add libav use flag
Package-Manager: portage-2.2.28
-rw-r--r--media-sound/kradio/files/kradio-4.0.7-include.patch4
-rw-r--r--media-sound/kradio/kradio-4.0.8.ebuild23
2 files changed, 14 insertions, 13 deletions
diff --git a/media-sound/kradio/files/kradio-4.0.7-include.patch b/media-sound/kradio/files/kradio-4.0.7-include.patch
index f5c2917de6db..4a0d6aaf6f5d 100644
--- a/media-sound/kradio/files/kradio-4.0.7-include.patch
+++ b/media-sound/kradio/files/kradio-4.0.7-include.patch
@@ -2,8 +2,8 @@ KDE4_INCLUDES also contains Qt includes required by KDE.
See FindKDE4Internal.cmake for more details.
Fixes Gentoo bug #510500.
---- CMakeLists.txt
-+++ CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -55,7 +55,7 @@
)
diff --git a/media-sound/kradio/kradio-4.0.8.ebuild b/media-sound/kradio/kradio-4.0.8.ebuild
index 6d4c7ebf9bd8..acd742a019e2 100644
--- a/media-sound/kradio/kradio-4.0.8.ebuild
+++ b/media-sound/kradio/kradio-4.0.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
KDE_LINGUAS_DIR=( po convert-presets/po )
PLUGINS=(
@@ -22,14 +22,15 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="4"
-IUSE="alsa debug encode ffmpeg lirc +mp3 +vorbis v4l"
+IUSE="alsa debug encode ffmpeg libav lirc +mp3 +vorbis v4l"
DEPEND="
media-libs/libsndfile
alsa? ( media-libs/alsa-lib )
ffmpeg? (
>=media-libs/libmms-0.4
- virtual/ffmpeg
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
)
lirc? ( app-misc/lirc )
mp3? ( media-sound/lame )
@@ -61,13 +62,13 @@ src_prepare() {
}
src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with alsa)
- $(cmake-utils_use_with ffmpeg)
- $(cmake-utils_use_with lirc)
- $(cmake-utils_use_with mp3 LAME)
- $(cmake-utils_use_with vorbis OGG_VORBIS)
- $(cmake-utils_use_with v4l V4L2)
+ local mycmakeargs=(
+ -DWITH_ALSA=$(usex alsa)
+ -DWITH_FFMPEG=$(usex ffmpeg)
+ -DWITH_LIRC=$(usex lirc)
+ -DWITH_LAME=$(usex mp3)
+ -DWITH_OGG_VORBIS=$(usex vorbis)
+ -DWITH_V4L2=$(usex v4l)
)
kde4-base_src_configure