summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-03-01 14:57:39 -0500
committerMike Pagano <mpagano@gentoo.org>2023-03-01 14:57:39 -0500
commit44156ce363d103b192bae659becf772e7100d4cb (patch)
tree26ff1906dfe14509f52b3e81cb4ceab897e71d4a
parentwww-servers/nginx-unit: Keep /var/lib/nginx-unit ownership (diff)
downloadgentoo-44156ce3.tar.gz
gentoo-44156ce3.tar.bz2
gentoo-44156ce3.zip
www-servers/nginx-unit: add 1.29.1
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.29.1.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index af881738fd54..fa2f4f5bf36f 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1 +1,2 @@
DIST nginx-unit-1.29.0.tar.gz 903909 BLAKE2B d9e2544ce7ffb4f9a510afaef2ddbf54a4482558d0cd3dd526c1371413e32fc72e848c95d3866928c1accc19bc2aecdb4c26b6907bfa57c382db53cc2f9fad3e SHA512 6b0a6718be5c3312f5e17fc39ae35ca849049c97d29c63a7effda7f994274af29eed88970389bb3010a2103c431e69920c951de5004853004d1aa604d868bd9f
+DIST nginx-unit-1.29.1.tar.gz 906654 BLAKE2B 1068a1002b05f6f9f28b19745e3c1c0f1d1def89fad8489174fd7b38ddd8c9678f27a3b105f98a17d537621cdd2cbedf9f39b4c284a7918d290287f3c324fa49 SHA512 c99cea78804ead999e62777132fe204e0f87e1b58e55b0b4a074ab8d203149c14c8faef64872a44404f8fca5bfd98d2f9e4aae2db89bebeee15f27cabbc9f247
diff --git a/www-servers/nginx-unit/nginx-unit-1.29.1.ebuild b/www-servers/nginx-unit/nginx-unit-1.29.1.ebuild
new file mode 100644
index 000000000000..944eabe1322d
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.29.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit flag-o-matic python-single-r1 systemd toolchain-funcs
+
+MY_P="unit-${PV}"
+DESCRIPTION="Dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php7-4 php8-0 php8-1 "
+IUSE="${MY_USE} ${MY_USE_PHP} ssl"
+REQUIRED_USE="|| ( ${IUSE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php7-4? ( dev-lang/php:7.4[embed] )
+ php8-0? ( dev-lang/php:8.0[embed] )
+ php8-1? ( dev-lang/php:8.1[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ dev-lang/ruby:=
+ dev-ruby/rubygems:=
+ )
+ ssl? ( dev-libs/openssl:0= )
+ virtual/libcrypt:0="
+RDEPEND="${DEPEND}
+ acct-user/nginx-unit
+ acct-group/nginx-unit"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+ sed -i '/^CFLAGS/d' auto/make || die
+ default
+}
+
+src_configure() {
+ local opt=(
+ --control=unix:/run/${PN}.sock
+ --log=/var/log/${PN}
+ --modules=$(get_libdir)/${PN}
+ --pid=/run/${PN}.pid
+ --prefix=/usr
+ --state=/var/lib/${PN}
+ --user=${PN}
+ --group=${PN}
+ )
+
+ use ssl && opt+=( --openssl )
+ export AR="$(tc-getAR)"
+ export CC="$(tc-getCC)"
+ ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
+
+ # Modules require position-independent code
+ append-cflags $(test-flags-CC -fPIC)
+
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
+ newconfd "${FILESDIR}"/nginx-unit.confd nginx-unit
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+}
+
+pkg_postinst() {
+ chown ${PN}:${PN} "${EROOT}"/var/lib/nginx-unit
+}