summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-12-20 16:08:49 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-12-20 16:17:50 -0500
commit442b53f090f22d3816aa9ff58834aee0c0007130 (patch)
treeaba9b45470b27b7c8a192cfad9d29ef17095b3ed
parentsci-mathematics/primesieve: add 11.0 (diff)
downloadgentoo-442b53f090f22d3816aa9ff58834aee0c0007130.tar.gz
gentoo-442b53f090f22d3816aa9ff58834aee0c0007130.tar.bz2
gentoo-442b53f090f22d3816aa9ff58834aee0c0007130.zip
sci-mathematics/primecount: add 7.6
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/primecount/Manifest1
-rw-r--r--sci-mathematics/primecount/primecount-7.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-mathematics/primecount/Manifest b/sci-mathematics/primecount/Manifest
index f9dc8e98b19c..108b8d583077 100644
--- a/sci-mathematics/primecount/Manifest
+++ b/sci-mathematics/primecount/Manifest
@@ -1 +1,2 @@
DIST primecount-7.4.tar.gz 372374 BLAKE2B ca16004e1a1fe209452d1c4aa9d4dfe7816ff581ffbb9717ae9a8224815df0b672871ec3d749000099a91c8ee50bcc3c43cea3dcb9ff999436544bed2c2f5fde SHA512 20b33a1c0d2338f422a0da8723bafd35689f9c93918c7dcf64068aee1cd5e03f41d0ef49e39a7e920828b478e8faeda4fea477dacca1145c852f24d1f5e6ab5b
+DIST primecount-7.6.tar.gz 382074 BLAKE2B f665db8724b32b2f057db96fdd6421d7a996ed4bda7f43cd405e6c05b59abab8672407c41b6fafdd9c68dae3f51b65305112c0724c95ce3fdb33b9dbfaadfbff SHA512 643372d9a011dba8a49f21eabc00068b77a5ef5dc6d12e6b55230b97f14dc9d1d855bb7ad662beda548e4ff1396f1b06d473e2fe4b81e7dbe9926aaadc4da360
diff --git a/sci-mathematics/primecount/primecount-7.6.ebuild b/sci-mathematics/primecount/primecount-7.6.ebuild
new file mode 100644
index 000000000000..4675e44b1d5d
--- /dev/null
+++ b/sci-mathematics/primecount/primecount-7.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Highly optimized CLI and library to count primes"
+HOMEPAGE="https://github.com/kimwalisch/primecount"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/7" # subslot is first component of libprimecount.so version
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_popcnt +executable openmp test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=sci-mathematics/primesieve-11.0:="
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/Credits.md
+ doc/Easy-Special-Leaves.md
+ doc/Hard-Special-Leaves.md
+ doc/Records.md
+ doc/References.md
+ doc/alpha-factor-dr.pdf
+ doc/alpha-factor-gourdon.pdf
+ doc/alpha-factor-lmo.pdf
+ doc/libprimecount.md
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_LIBPRIMESIEVE="OFF"
+ -DBUILD_PRIMECOUNT="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ -DWITH_OPENMP="$(usex openmp)"
+ -DWITH_POPCNT="$(usex cpu_flags_x86_popcnt)"
+ )
+
+ cmake_src_configure
+}