summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-09-01 13:33:09 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-09-01 13:33:53 +0100
commit44350e8fd19acc4020b7524768ffdb4dfcd06f38 (patch)
tree82be5242d8ba26c6498b84c25a85c9d1b9eaa34e
parentnet-misc/iperf: Fix USE=-ipv6 (diff)
downloadgentoo-44350e8f.tar.gz
gentoo-44350e8f.tar.bz2
gentoo-44350e8f.zip
dev-lua/luasocket: Patch to fix proxy variable issue, EAPI 7
This is needed for games-simulation/corsix-th, which I will add back into the repository. Closes: https://bugs.gentoo.org/585962 Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--dev-lua/luasocket/files/proxy-fix.patch31
-rw-r--r--dev-lua/luasocket/luasocket-3.0_rc1-r4.ebuild55
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-lua/luasocket/files/proxy-fix.patch b/dev-lua/luasocket/files/proxy-fix.patch
new file mode 100644
index 000000000000..302e63663ff7
--- /dev/null
+++ b/dev-lua/luasocket/files/proxy-fix.patch
@@ -0,0 +1,31 @@
+From 1f9ccb2b586c3a7e29db3c99a23ac1cee6907cf2 Mon Sep 17 00:00:00 2001
+From: Pierre Chapuis <catwell@archlinux.us>
+Date: Fri, 5 Jul 2013 18:00:29 +0200
+Subject: [PATCH] http: look for PROXY in _M, not as a global
+
+---
+ src/http.lua | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/http.lua b/src/http.lua
+index 5f70a374..f83dcc55 100644
+--- a/src/http.lua
++++ b/src/http.lua
+@@ -186,7 +186,7 @@ end
+ local function adjusturi(reqt)
+ local u = reqt
+ -- if there is a proxy, we need the full url. otherwise, just a part.
+- if not reqt.proxy and not PROXY then
++ if not reqt.proxy and not _M.PROXY then
+ u = {
+ path = socket.try(reqt.path, "invalid path 'nil'"),
+ params = reqt.params,
+@@ -198,7 +198,7 @@ local function adjusturi(reqt)
+ end
+
+ local function adjustproxy(reqt)
+- local proxy = reqt.proxy or PROXY
++ local proxy = reqt.proxy or _M.PROXY
+ if proxy then
+ proxy = url.parse(proxy)
+ return proxy.host, proxy.port or 3128
diff --git a/dev-lua/luasocket/luasocket-3.0_rc1-r4.ebuild b/dev-lua/luasocket/luasocket-3.0_rc1-r4.ebuild
new file mode 100644
index 000000000000..9789a03154f5
--- /dev/null
+++ b/dev-lua/luasocket/luasocket-3.0_rc1-r4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib multilib-minimal flag-o-matic
+
+DESCRIPTION="Networking support library for the Lua language"
+HOMEPAGE="http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/"
+SRC_URI="https://github.com/diegonehab/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/lua-5.1.5-r2[deprecated,${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${PN}-${PV/_/-}
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/proxy-fix.patch
+)
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ LD="$(tc-getCC) ${LDFLAGS}"\
+ $(usex debug DEBUG="DEBUG" "")
+}
+
+multilib_src_install() {
+ local luav=$($(tc-getPKG_CONFIG) --variable V lua)
+ emake \
+ DESTDIR="${D}" \
+ LUAPREFIX_linux=/usr \
+ LUAV=${luav} \
+ CDIR_linux=$(get_libdir)/lua/${luav} \
+ install-unix
+}
+
+multilib_src_install_all() {
+ dodoc NEW README
+ docinto html
+ dodoc -r doc/.
+}