summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 07:55:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 08:34:04 +0200
commit4442686a37fa7ec3c0edc56b792976de4ed5225d (patch)
tree41869fb96d4ebd12866b4715f4d4bab2bac8d190
parentdev-python/coverage: Bump to 6.4 (diff)
downloadgentoo-4442686a37fa7ec3c0edc56b792976de4ed5225d.tar.gz
gentoo-4442686a37fa7ec3c0edc56b792976de4ed5225d.tar.bz2
gentoo-4442686a37fa7ec3c0edc56b792976de4ed5225d.zip
dev-python/PyPDF2: Bump to 1.28.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyPDF2/Manifest1
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.28.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/Manifest b/dev-python/PyPDF2/Manifest
index 3b94bc368208..b0dce1533d24 100644
--- a/dev-python/PyPDF2/Manifest
+++ b/dev-python/PyPDF2/Manifest
@@ -1,2 +1,3 @@
DIST PyPDF2-1.27.12.gh.tar.gz 3430850 BLAKE2B a0cb344f616d628b7c39dc360234057ce68595ffa554a8588990ef0a1239ade2db6415caefb84bc058d89067ed04ba66ba149f6f106bbf9a55a13f523dd826fc SHA512 ee00c975881b7e6716656b1cecb83c3e1f7bffa4ed9fb0d8c8be45c7d951b2b79f0be4f9098569bad783703fbc00f0797e73b970b02adad1ed3a4cf3b6ab7b73
+DIST PyPDF2-1.28.1.gh.tar.gz 4260569 BLAKE2B 69b925a463c262ab207dd768160ea9083b14eed6a25a234d09e472ce812039aeb899674a0216b20ead3a4814cc3ec83ee320c99b84d109d8a320b925b7654ffa SHA512 22dec520e256420b618d5611f44f52752ad3c7ccee325991f4817e88ba69d01bf705708877a0df450297c3231725f72e03c4d8b33ced29fd7445c0ac2701dc2b
DIST PyPDF2-sample-files-41b5cd4f774f8fbd8ac42d93b9962f0376352a15.tar.gz 5406287 BLAKE2B 8ddad01235bdb55cee596d9114e5b6c3b153919bcff5203d229311243516f3595cb36dcca87cae27514a8231d72daa94782115795bff8c1c3d046236811c21e0 SHA512 6c38d5ee0e1c5c0ffdd78f7c2fe56dbf357a1e82d2af642a10264a6102ae8fb95cba6d2f76b26df6a33a5d84cfd5111885d39c1747cf95a5ce545f26bdb37263
diff --git a/dev-python/PyPDF2/PyPDF2-1.28.1.ebuild b/dev-python/PyPDF2/PyPDF2-1.28.1.ebuild
new file mode 100644
index 000000000000..e77867c450d2
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-1.28.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=41b5cd4f774f8fbd8ac42d93b9962f0376352a15
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/PyPDF2/
+ https://github.com/py-pdf/PyPDF2/
+"
+SRC_URI="
+ https://github.com/py-pdf/PyPDF2/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${P}"/sample-files/ || die
+ fi
+}
+
+src_install() {
+ if use examples; then
+ docinto examples
+ dodoc -r Sample_Code/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_src_install
+}