summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2019-05-04 00:34:07 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-05 09:47:11 +0200
commit44438532eb16f8929e0ca80a32105a25a3b61395 (patch)
tree68388d9639d9c26a27b666397cd2a8b71aa9eab0
parentdev-python/mygpoclient: x86 stable wrt bug #681376 (diff)
downloadgentoo-44438532.tar.gz
gentoo-44438532.tar.bz2
gentoo-44438532.zip
app-editors/ghostwriter: verbump to 1.8.0
Closes: https://bugs.gentoo.org/684680 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11889 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-editors/ghostwriter/Manifest1
-rw-r--r--app-editors/ghostwriter/ghostwriter-1.8.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-editors/ghostwriter/Manifest b/app-editors/ghostwriter/Manifest
index 0bd394321c38..38949299e56d 100644
--- a/app-editors/ghostwriter/Manifest
+++ b/app-editors/ghostwriter/Manifest
@@ -1,3 +1,4 @@
DIST ghostwriter-1.5.0.tar.gz 620301 BLAKE2B 07af6c6b176f15a7b6bee0594936a346160783c553dfd91cd69bde3975ada5c125920c1029ab19aee21c89576c6fab311f7a893447c457ff5a174149e57f67bb SHA512 4b6e1430342069b224f7aece30d5a592a43e9f702cb93fc073fded741771ea74b8478203aeaecdabb791aa7ddd8055d5c36346518adc7dd19b61e5f2e2cbe219
DIST ghostwriter-1.7.3.tar.gz 673328 BLAKE2B 5304f5218da5fe535dea1ed9d43c4358212d9b1025dcc7102a77852c833ba1301d59539df4e2a44fd8a46abe7dfbdc7c6ab490d3f9e8ed5f7b4571b604c3bbb6 SHA512 a6f7e64078bdb3ecd9ea48ead8e96811e62215292a1c4a269f23efb6c0403c62fb0aab3e1303397b08036a7f3507d04a8eb8c14baafd78f64fea20805bb24a5a
DIST ghostwriter-1.7.4.tar.gz 1195162 BLAKE2B 6339161b73b6e8cf9fce37da5133416512a61289189fb3f574af96753e62e8e364d610dd277542bd18b4ec44692dc149d4b3d5a6cd89894536d4dc898994c667 SHA512 b09e0f8152cd8bdd4465f20d94134ea6ef840b4ccd6d9f75bce8452917d98adc89093c661ecde0400fba7d68f832633c8fe0b19a1607ce79e3f400caa573da8f
+DIST ghostwriter-1.8.0.tar.gz 1195999 BLAKE2B d751e570aed94bcf0806ca20d82b0ac2b465649caf31f01b761f0370a4f1b04ac8f948213b15c05a71541b8068ef21dfb2105b5fc91d5637e498e2d4c8f6bf9a SHA512 aff500d9221f28f6a06a93bf0b5ddb590792b22bc551749b790f52751cd7f2e27ea59778927c2f117320cb1791b45d51d8efdf479f0894319755afb1a509f7bd
diff --git a/app-editors/ghostwriter/ghostwriter-1.8.0.ebuild b/app-editors/ghostwriter/ghostwriter-1.8.0.ebuild
new file mode 100644
index 000000000000..a6fa48460be7
--- /dev/null
+++ b/app-editors/ghostwriter/ghostwriter-1.8.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
+HOMEPAGE="https://wereturtle.github.io/ghostwriter/"
+SRC_URI="https://github.com/wereturtle/ghostwriter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+BDEPEND="dev-qt/linguist-tools:5"
+
+RDEPEND="
+ app-text/hunspell
+ dev-qt/qtwebchannel:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CREDITS.md README.md )
+
+src_prepare() {
+ default
+
+ sed -i -e "/^VERSION =/s/\$.*/${PV}/" ghostwriter.pro || die "failed to override version"
+}
+
+src_configure() {
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}