summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-09-08 21:11:10 +0200
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-09-14 08:06:29 +0100
commit4443cbeea54b0100b3c8557fa676d00b63782735 (patch)
treed37a58ca8e7ebbb9f87fbe2d0e809c1de4423914
parentdev-haskell/lifted-async: remove unused patch(es) (diff)
downloadgentoo-4443cbee.tar.gz
gentoo-4443cbee.tar.bz2
gentoo-4443cbee.zip
net-im/profanity: bump to 0.9.5
Closes: https://bugs.gentoo.org/708078 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/profanity-0.9.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index 856411b5b46f..01eb33cfbc42 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1,2 +1,3 @@
DIST profanity-0.6.0.tar.gz 741812 BLAKE2B ba6cff070ee0e8a83b52677f6551c1d7397cd25993982d6b5390590a4924d902050504cb8803ee2741262b1409e4d75e9f223397f87f39d7dc86fcc56a0e5df6 SHA512 c7d8e74b764276f59fccfa029d45271032db315cdbf6e00deccbd611f202983a0930fed99021202333047acee9f3f0d7779cd9bb3628d2e5c4757e3de8c3629e
DIST profanity-0.7.1.tar.gz 788754 BLAKE2B 447c761233ce6989081d3ed7a585d90713f4266dfc22ff816aea7c014f642f57989f7f767d8cf40cdd36c3152f45c6700f3905e0d12b864533aac61ac4dc7aaa SHA512 a6e159a5452ebb193dcff74dc8673de5dbc4bc5b2f2b8abc129641fc1b4b370aee9617dc0b26cfcc6aae58a1a900fda29356e61cdc17ee7ba69c879d6ccc2339
+DIST profanity-0.9.5.tar.gz 830966 BLAKE2B fc1b755b1a92dbde62aacb31cb5d9190cea951e98501a5b48495dbd31266f343cf436de1fa0f69caec34324cd1f781d0bd4f5f7ebdd984324c5d1d6edb91452a SHA512 79305ee488d3a9b87bb422d6525bfaae62c4969d466b968c86941ed5bf0c0080e349758f2e1ead144693513b5d19a635372e73aa1fe9e362836b9245e1d2b898
diff --git a/net-im/profanity/profanity-0.9.5.ebuild b/net-im/profanity/profanity-0.9.5.ebuild
new file mode 100644
index 000000000000..4de859fde22c
--- /dev/null
+++ b/net-im/profanity/profanity-0.9.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="https://profanity-im.github.io"
+SRC_URI="https://profanity-im.github.io/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="libnotify omemo otr gpg test xscreensaver"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-db/sqlite
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/libstrophe:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/ncurses:=[unicode]
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ omemo? (
+ net-libs/libsignal-protocol-c
+ dev-libs/libgcrypt
+ )
+ otr? ( net-libs/libotr )
+ test? ( dev-util/cmocka )
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11 )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable omemo) \
+ $(use_enable otr) \
+ $(use_enable gpg pgp) \
+ $(use_with xscreensaver)
+}