summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-19 20:06:55 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-31 14:45:56 +0300
commit444d977c050910702fa3a6f0ffb3e6ba1800a291 (patch)
tree7b1cac32fdf836f86401da6853c9483316719d61
parentdev-embedded/esptool: remove old (diff)
downloadgentoo-444d977c050910702fa3a6f0ffb3e6ba1800a291.tar.gz
gentoo-444d977c050910702fa3a6f0ffb3e6ba1800a291.tar.bz2
gentoo-444d977c050910702fa3a6f0ffb3e6ba1800a291.zip
x11-plugins/gkwebmon: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Closes: https://github.com/gentoo/gentoo/pull/24724 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild b/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild
new file mode 100644
index 000000000000..83494004e3b5
--- /dev/null
+++ b/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A web monitor plugin for GKrellM2"
+HOMEPAGE="http://gkwebmon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+# The Makefile links with -lssl.
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ dev-libs/openssl"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cc-cflags-ldflags.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+
+ emake CC="$(tc-getCC)"
+}