summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-03-28 18:06:23 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-03-28 18:16:05 -0400
commit445ce5ec37b42891744020453956d5035501dbad (patch)
treeb98da19a033201d6af6b8e0cd6eb82c49685e3b6
parentdev-util/buildbot: Version bump to 3.0.2, adds py3.9 (diff)
downloadgentoo-445ce5ec37b42891744020453956d5035501dbad.tar.gz
gentoo-445ce5ec37b42891744020453956d5035501dbad.tar.bz2
gentoo-445ce5ec37b42891744020453956d5035501dbad.zip
dev-util/buildbot-worker: Version bump to 3.0.2, adds py3.9
Update 9999 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
-rw-r--r--dev-util/buildbot-worker/Manifest1
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-3.0.2.ebuild126
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-9999.ebuild4
3 files changed, 129 insertions, 2 deletions
diff --git a/dev-util/buildbot-worker/Manifest b/dev-util/buildbot-worker/Manifest
index 86b2b49ce726..3a2419e11319 100644
--- a/dev-util/buildbot-worker/Manifest
+++ b/dev-util/buildbot-worker/Manifest
@@ -2,3 +2,4 @@ DIST buildbot-worker-2.10.0.tar.gz 107279 BLAKE2B 415b950b81862ac4c08ca00217e273
DIST buildbot-worker-2.10.1.tar.gz 107656 BLAKE2B 8b94ecacc18f1e1f2e58d64f223f77af31454a3b199de9ee4c5a174b2cb645a970614674f5917415c4ab6d1ee0180ff99fbf4f121339eb05fcd80b363bfad3c0 SHA512 93f684c36e7c07c90e24a666084734df33d30376436b50db74ae8bd3b3a5e306799d15bd03d93b02f723bdf878adbfe17bbc59fd9f49f43431aea90612113ed7
DIST buildbot-worker-2.8.2.tar.gz 101707 BLAKE2B 451dff979c6934bf6dd4e1579abbe18e9cf43551c906bd516c788a6a5f6170650a5468927bec0a8d4ab242e5886247406b2e098e1908a8d9b5777744982c7be6 SHA512 0628825ac023a66cd249dc6b42ff2f3ad3b5c0cb97561fd332ce4775abaa5368a8b7b636115259ab4aa842c811178c9b641ef4453b06167315eb81117ffef815
DIST buildbot-worker-2.8.4.tar.gz 101175 BLAKE2B 23077305d26ab282eaa4c633ebee7ca7c502285862604ecafe25d6b666ce802729c5478d676e6834bf9a2e27ccf48e1ad0e69449e55532aa81b0dcd3c6780011 SHA512 16ad9a0e5e9c875f90383fc90c359ee843e0b82a7878f87f2ac9e7091d8d907707c69210876f25b4fdf7148bcaafab10d10a8a0a8865c73808db707320757107
+DIST buildbot-worker-3.0.2.tar.gz 96923 BLAKE2B 720d265381c0dc4f876ba1c87df893d8adbb153fef8dd78f6d84b24cbf43d7637fb2f58fd4e312724e9fab3318c2ba6fb6bd7a881989790edc1e9aa02095543d SHA512 d970568bdec9d201699350383dfbcf9e915a75d2cc5f69c0af9db009ce1bf5dbed83302bcc6c7e34fdcc2aa739675a7bd14fda686900b05a32ae83cca6a2da10
diff --git a/dev-util/buildbot-worker/buildbot-worker-3.0.2.ebuild b/dev-util/buildbot-worker/buildbot-worker-3.0.2.ebuild
new file mode 100644
index 000000000000..6f105d83f93e
--- /dev/null
+++ b/dev-util/buildbot-worker/buildbot-worker-3.0.2.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="BuildBot Worker (slave) Daemon"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-worker/"
+
+MY_V="${PV/_p/.post}"
+MY_P="${PN}-${MY_V}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-user/buildbot
+ >=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ !<dev-util/buildbot-1.0.0
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/setuptools_trial[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
+ to support starting buildbot_worker through Gentoo's init system. To use this,
+ execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
+ Set up your build worker following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${ROOT}/etc/conf.d/buildbot_worker.myinstance\" at the right location.
+ The scripts can run as a different user if desired."
+}
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman docs/buildbot-worker.1
+
+ newconfd "${FILESDIR}/buildbot_worker.confd2" buildbot_worker
+ newinitd "${FILESDIR}/buildbot_worker.initd2" buildbot_worker
+
+ dodir /var/lib/buildbot_worker
+ cp "${FILESDIR}/buildbot.tac.sample" "${D}/var/lib/buildbot_worker"|| die "Install failed!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ ewarn
+ ewarn "More than one instance of a buildbot_worker can be run simultaneously."
+ ewarn " Note that \"BASEDIR\" in the buildbot_worker configuration file"
+ ewarn "is now the common base directory for all instances. If you are migrating from an older"
+ ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
+ ewarn "The name of the subdirectory corresponds to the name of the buildbot_worker instance."
+ ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
+ ewarn " ln --symbolic --relative /etc/init.d/buildbot_worker /etc/init.d/buildbot_worker.myinstance"
+ ewarn " rc-update add buildbot_worker.myinstance default"
+ ewarn " /etc/init.d/buildbot_worker.myinstance start"
+ ewarn "Systems using systemd can do the following:"
+ ewarn " systemctl enable buildbot_worker@myinstance.service"
+ ewarn " systemctl enable buildbot_worker.target"
+ ewarn " systemctl start buildbot_worker.target"
+ fi
+}
+
+pkg_config() {
+ local buildworker_path="/var/lib/buildbot_worker"
+ local log_path="/var/log/buildbot_worker"
+
+ einfo "This will prepare a new buildbot_worker instance in ${buildworker_path}."
+ einfo "Press Control-C to abort."
+
+ einfo "Enter the name for the new instance: "
+ read instance_name
+ [[ -z "${instance_name}" ]] && die "Invalid instance name"
+
+ local instance_path="${buildworker_path}/${instance_name}"
+ local instance_log_path="${log_path}/${instance_name}"
+
+ if [[ -e "${instance_path}" ]]; then
+ eerror "The instance with the specified name already exists:"
+ eerror "${instance_path}"
+ die "Instance already exists"
+ fi
+
+ if [[ ! -d "${instance_path}" ]]; then
+ mkdir --parents "${instance_path}" || die "Unable to create directory ${buildworker_path}"
+ fi
+ chown --recursive buildbot:buildbot "${instance_path}" || die "Setting permissions for instance failed"
+ cp "${buildworker_path}/buildbot.tac.sample" "${instance_path}/buildbot.tac" \
+ || die "Moving sample configuration failed"
+ ln --symbolic --relative "/etc/init.d/buildbot_worker" "/etc/init.d/buildbot_worker.${instance_name}" \
+ || die "Unable to create link to init file"
+
+ if [[ ! -d "${instance_log_path}" ]]; then
+ mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
+ chown --recursive buildbot:buildbot "${instance_log_path}" \
+ || die "Setting permissions for instance failed"
+ fi
+ ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
+ || die "Unable to create link to log file"
+
+ einfo "Successfully created a buildbot_worker instance at ${instance_path}."
+ einfo "To change the default settings edit the buildbot.tac file in this directory."
+}
diff --git a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
index f632c94e16c1..605f3460526d 100644
--- a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
+++ b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"