summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-01 18:10:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-01 19:53:33 +0200
commit446dde5f9155ab7b0ad150c86a74c75df0e841dd (patch)
treefe38ea5287944194fd3bb46a7b9ce35d6167f011
parentmedia-video/obs-studio: sync live (diff)
downloadgentoo-446dde5f.tar.gz
gentoo-446dde5f.tar.bz2
gentoo-446dde5f.zip
dev-python/argon2-cffi: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-20.1.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/argon2-cffi/argon2-cffi-20.1.0.ebuild b/dev-python/argon2-cffi/argon2-cffi-20.1.0.ebuild
index 8f2dbc345dd9..d86638c7966e 100644
--- a/dev-python/argon2-cffi/argon2-cffi-20.1.0.ebuild
+++ b/dev-python/argon2-cffi/argon2-cffi-20.1.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
@@ -33,3 +33,12 @@ distutils_enable_tests pytest
python_configure_all() {
export ARGON2_CFFI_USE_SYSTEM=1
}
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # fails due to changed Enum repr
+ tests/test_utils.py::TestParameters::test_repr
+ )
+ epytest ${deselect[@]/#/--deselect }
+}