summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-02 16:21:45 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-02 16:21:45 -0600
commit44711d3988a18ae2953421f20c0572e93eaf8975 (patch)
treeebdb83be8982df40356d0f5841ba6bd925791eaa
parentsys-auth/polkit-qt: depend on polkit[daemon(+)] (diff)
downloadgentoo-44711d39.tar.gz
gentoo-44711d39.tar.bz2
gentoo-44711d39.zip
app-containers/runc: add 1.1.4
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-containers/runc/Manifest1
-rw-r--r--app-containers/runc/runc-1.1.4.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-containers/runc/Manifest b/app-containers/runc/Manifest
index a2c2fb30da3f..5f8b6d16045a 100644
--- a/app-containers/runc/Manifest
+++ b/app-containers/runc/Manifest
@@ -1 +1,2 @@
DIST runc-1.1.3.tar.gz 2333384 BLAKE2B 7530faa80a6d51c840a1ea702ec59580a3e42514f5932a7dd4df9f80ff93245bde05accd572a942190b6be76316f38a408566b003ad380611376e73abe3cb5c0 SHA512 27fce2569d0dc710a0f90095957be30c29da24ce1d2b8e115b9dc11d36f5226d98c4b2d8b92ecfa7581eade90bc51c5d9bccaf15fcb2542dafebe4fabc6e1cd9
+DIST runc-1.1.4.tar.gz 2334639 BLAKE2B bc7eb7de29e8ebb9ce146bc77bf6cfc116f4af3e28c0344059183cf0c8082c629ccb235531c368cce99915991b25df0b50b7cbb98b9c6a7d141ba6cc15958651 SHA512 c8e79ad839964680d29ab56a4de255f91192741951673025da6889c544a232d4d392db2da8005d8e22999a37bfbc9c9fe7f6043b165bc4edc2f2a29261d8a3d6
diff --git a/app-containers/runc/runc-1.1.4.ebuild b/app-containers/runc/runc-1.1.4.ebuild
new file mode 100644
index 000000000000..e54c791a9b78
--- /dev/null
+++ b/app-containers/runc/runc-1.1.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module linux-info
+
+# update on bump, look for https://github.com/docker\
+# docker-ce/blob/<docker ver OR branch>/components/engine/hack/dockerfile/install/runc.installer
+RUNC_COMMIT=5fd4c4d144137e991c4acebb2146ab1483a97925
+CONFIG_CHECK="~USER_NS"
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://github.com/opencontainers/runc/"
+MY_PV="${PV/_/-}"
+SRC_URI="https://github.com/opencontainers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="apparmor hardened +kmem +seccomp selinux test"
+
+DEPEND="seccomp? ( sys-libs/libseccomp )"
+
+RDEPEND="
+ ${DEPEND}
+ !app-emulation/docker-runc
+ apparmor? ( sys-libs/libapparmor )
+ selinux? ( sec-policy/selinux-container )
+"
+
+BDEPEND="
+ dev-go/go-md2man
+ test? ( "${RDEPEND}" )
+"
+
+# tests need busybox binary, and portage namespace
+# sandboxing disabled: mount-sandbox pid-sandbox ipc-sandbox
+# majority of tests pass
+RESTRICT+=" test"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ # Taken from app-containers/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ESYSROOT}/usr/$(get_libdir)"
+
+ # build up optional flags
+ local options=(
+ $(usev apparmor)
+ $(usev seccomp)
+ $(usex kmem '' 'nokmem')
+ )
+
+ myemakeargs=(
+ BUILDTAGS="${options[*]}"
+ COMMIT="${RUNC_COMMIT}"
+ )
+
+ emake "${myemakeargs[@]}" runc man
+}
+
+src_install() {
+ myemakeargs+=(
+ PREFIX="${ED}/usr"
+ BINDIR="${ED}/usr/bin"
+ MANDIR="${ED}/usr/share/man"
+ )
+ emake "${myemakeargs[@]}" install install-man install-bash
+
+ local DOCS=( README.md PRINCIPLES.md docs/. )
+ einstalldocs
+}
+
+src_test() {
+ emake "${myemakeargs[@]}" localunittest
+}