summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-05 20:36:52 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-05 20:36:52 -0800
commit4480ad059cf7edb93dee4f70790c940951bde781 (patch)
treef863cb7a34c2bc09f4ece0fe6647799bbe8ac278
parentdev-lua/lua-openssl-0.7.7_p0-r1: revbump, fix libdir (diff)
downloadgentoo-4480ad059cf7edb93dee4f70790c940951bde781.tar.gz
gentoo-4480ad059cf7edb93dee4f70790c940951bde781.tar.bz2
gentoo-4480ad059cf7edb93dee4f70790c940951bde781.zip
dev-python/pytest-cov-2.8.1: Add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch40
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch52
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.8.1.ebuild5
3 files changed, 96 insertions, 1 deletions
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch
new file mode 100644
index 000000000000..8a9618c3fd98
--- /dev/null
+++ b/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch
@@ -0,0 +1,40 @@
+diff --git a/setup.py b/setup.py
+index 1305b23..3a5803e 100644
+--- a/setup.py
++++ b/setup.py
+@@ -29,7 +29,7 @@ def read(*names, **kwargs):
+
+
+ class BuildWithPTH(build):
+- def run(self):
++ def run(self, **kwargs):
+ build.run(self)
+ path = join(dirname(__file__), 'src', 'pytest-cov.pth')
+ dest = join(self.build_lib, basename(path))
+@@ -37,7 +37,7 @@ class BuildWithPTH(build):
+
+
+ class EasyInstallWithPTH(easy_install):
+- def run(self):
++ def run(self, **kwargs):
+ easy_install.run(self)
+ path = join(dirname(__file__), 'src', 'pytest-cov.pth')
+ dest = join(self.install_dir, basename(path))
+@@ -45,7 +45,7 @@ class EasyInstallWithPTH(easy_install):
+
+
+ class InstallLibWithPTH(install_lib):
+- def run(self):
++ def run(self, **kwargs):
+ install_lib.run(self)
+ path = join(dirname(__file__), 'src', 'pytest-cov.pth')
+ dest = join(self.install_dir, basename(path))
+@@ -57,7 +57,7 @@ class InstallLibWithPTH(install_lib):
+
+
+ class DevelopWithPTH(develop):
+- def run(self):
++ def run(self, **kwargs):
+ develop.run(self)
+ path = join(dirname(__file__), 'src', 'pytest-cov.pth')
+ dest = join(self.install_dir, basename(path))
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch
new file mode 100644
index 000000000000..6292672b6191
--- /dev/null
+++ b/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch
@@ -0,0 +1,52 @@
+diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
+index e79e9aa..198478b 100644
+--- a/tests/test_pytest_cov.py
++++ b/tests/test_pytest_cov.py
+@@ -662,6 +662,7 @@ def test_fail(p):
+ ])
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="Seems buggy on python3.8")
+ @pytest.mark.skipif('sys.platform == "win32" or platform.python_implementation() == "PyPy"')
+ def test_dist_combine_racecondition(testdir):
+ script = testdir.makepyfile("""
+@@ -1018,6 +1019,7 @@ def test_funcarg_not_active(testdir):
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif("sys.version_info[0] < 3", reason="no context manager api on Python 2")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ @pytest.mark.skipif('platform.python_implementation() == "PyPy"', reason="often deadlocks on PyPy")
+@@ -1059,6 +1061,7 @@ def test_run_target():
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ @pytest.mark.skipif('platform.python_implementation() == "PyPy"', reason="often deadlocks on PyPy")
+ def test_multiprocessing_pool_terminate(testdir):
+@@ -1141,6 +1144,7 @@ def test_run_target():
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ def test_multiprocessing_process(testdir):
+ pytest.importorskip('multiprocessing.util')
+@@ -1171,6 +1175,7 @@ def test_run_target():
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ def test_multiprocessing_process_no_source(testdir):
+ pytest.importorskip('multiprocessing.util')
+@@ -1201,6 +1206,7 @@ def test_run_target():
+ assert result.ret == 0
+
+
++@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
+ @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
+ def test_multiprocessing_process_with_terminate(testdir):
+ pytest.importorskip('multiprocessing.util')
diff --git a/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
index 45ad4ec70c7d..ac1732bd7f24 100644
--- a/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
inherit distutils-r1
@@ -35,6 +35,9 @@ DEPEND="
PATCHES=(
# Bug 597708
"${FILESDIR}/${PN}-2.8.1-disable-broken-tests.patch"
+ "${FILESDIR}/${PN}-2.8.1-latest-setuptools.patch"
+ # https://github.com/pytest-dev/pytest-cov/issues/365
+ "${FILESDIR}/pytest-cov-2.8.1-python38.patch"
)
distutils_enable_sphinx docs \