summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-05 17:08:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-05 17:54:46 +0200
commit448467a41fcaf8c70413e45cba5b91b988c26154 (patch)
tree5bc5748fb912fa36be81c9612aaf2d31489109f7
parentapp-office/libreoffice: DEPEND on dev-db/firebird[server] (diff)
downloadgentoo-448467a41fcaf8c70413e45cba5b91b988c26154.tar.gz
gentoo-448467a41fcaf8c70413e45cba5b91b988c26154.tar.bz2
gentoo-448467a41fcaf8c70413e45cba5b91b988c26154.zip
app-office/libreoffice: Fix build with -flto*
Closes: https://bugs.gentoo.org/650208 Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--app-office/libreoffice/libreoffice-6.0.9999.ebuild2
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/app-office/libreoffice/libreoffice-6.0.9999.ebuild b/app-office/libreoffice/libreoffice-6.0.9999.ebuild
index dcbfe6a9d252..7b989b3abd12 100644
--- a/app-office/libreoffice/libreoffice-6.0.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.0.9999.ebuild
@@ -483,6 +483,8 @@ src_configure() {
myeconfargs+=( --with-rhino-jar=$(java-pkg_getjar rhino-1.6 js.jar) )
fi
+ is-flagq "-flto*" && myeconfargs+=( --enable-lto )
+
econf "${myeconfargs[@]}"
}
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 23aa3d2795c4..271f47c5cc6c 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -482,6 +482,8 @@ src_configure() {
myeconfargs+=( --with-rhino-jar=$(java-pkg_getjar rhino-1.6 js.jar) )
fi
+ is-flagq "-flto*" && myeconfargs+=( --enable-lto )
+
econf "${myeconfargs[@]}"
}