summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-05-29 10:50:32 +0200
committerPacho Ramos <pacho@gentoo.org>2023-05-29 10:50:32 +0200
commit448aa70aeb5890d17fa2ffe349c5203b58c5871d (patch)
treef3c862fab15ac0b1f9d169cc354c0a299d1e8e7c
parentdev-python/flask: Enable py3.12 (diff)
downloadgentoo-448aa70a.tar.gz
gentoo-448aa70a.tar.bz2
gentoo-448aa70a.zip
media-gfx/gthumb: Rename USE "http" to "webkit"
That allows people wanting to globally avoid pulling in webkit-gtk to do it more easily. Also apply upstream fix for date formatting not being used properly. Closes: https://bugs.gentoo.org/907203 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--media-gfx/gthumb/files/3.12.2-date-format.patch32
-rw-r--r--media-gfx/gthumb/gthumb-3.12.2-r5.ebuild112
2 files changed, 144 insertions, 0 deletions
diff --git a/media-gfx/gthumb/files/3.12.2-date-format.patch b/media-gfx/gthumb/files/3.12.2-date-format.patch
new file mode 100644
index 000000000000..1bc2309abf20
--- /dev/null
+++ b/media-gfx/gthumb/files/3.12.2-date-format.patch
@@ -0,0 +1,32 @@
+https://gitlab.gnome.org/GNOME/gthumb/-/issues/235
+
+From 77b0e6186579fccfca8a516b1399564228e01793 Mon Sep 17 00:00:00 2001
+From: Paolo Bacchilega <paobac@src.gnome.org>
+Date: Wed, 10 Aug 2022 07:49:00 +0200
+Subject: [PATCH] rename series: fixed date format not applied correctly
+
+Closes #235
+---
+ extensions/rename_series/dlg-rename-series.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/extensions/rename_series/dlg-rename-series.c b/extensions/rename_series/dlg-rename-series.c
+index 60c784fe..cc0612da 100644
+--- a/extensions/rename_series/dlg-rename-series.c
++++ b/extensions/rename_series/dlg-rename-series.c
+@@ -162,6 +162,12 @@ template_eval_cb (TemplateFlags flags,
+ char *path;
+ GTimeVal timeval;
+
++ if ((parent_code == 'D') || (parent_code == 'M')) {
++ /* strftime code, return the code itself. */
++ _g_string_append_template_code (result, code, args);
++ return FALSE;
++ }
++
+ switch (code) {
+ case '#':
+ text = _g_template_replace_enumerator (args[0], template_data->n);
+--
+GitLab
+
diff --git a/media-gfx/gthumb/gthumb-3.12.2-r5.ebuild b/media-gfx/gthumb/gthumb-3.12.2-r5.ebuild
new file mode 100644
index 000000000000..043f387c00a2
--- /dev/null
+++ b/media-gfx/gthumb/gthumb-3.12.2-r5.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Image viewer and browser for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gthumb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cdr colord exif keyring gstreamer heif jpegxl lcms raw slideshow svg tiff webkit webp"
+
+# libX11 dep is a workaround. See files/3.12.2-link-with-x11.patch
+RDEPEND="
+ x11-libs/libX11
+
+ >=dev-libs/glib-2.54.0:2
+ >=x11-libs/gtk+-3.16.0:3
+ exif? ( >=media-gfx/exiv2-0.21:= )
+ slideshow? (
+ >=media-libs/clutter-1.12.0:1.0
+ >=media-libs/clutter-gtk-1:1.0
+ )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-plugins/gst-plugins-gtk:1.0
+ )
+ raw? (
+ >=media-libs/libraw-0.14:=
+ )
+ webkit? (
+ >=net-libs/libsoup-2.42.0:2.4
+ >=dev-libs/json-glib-0.15.0
+ >=net-libs/webkit-gtk-1.10.0:4
+ )
+ keyring? ( >=app-crypt/libsecret-0.11 )
+ cdr? ( >=app-cdr/brasero-3.2.0 )
+ svg? ( >=gnome-base/librsvg-2.34:2 )
+ webp? ( >=media-libs/libwebp-0.2.0:= )
+ jpegxl? ( >=media-libs/libjxl-0.3.0 )
+ heif? ( >=media-libs/libheif-1.11:= )
+ lcms? ( >=media-libs/lcms-2.6:2 )
+ colord? (
+ >=x11-misc/colord-1.3
+ >=media-libs/lcms-2.6:2
+ )
+
+ sys-libs/zlib
+ media-libs/libjpeg-turbo:=
+ tiff? ( media-libs/tiff:= )
+ media-libs/libpng:0=
+ >=gnome-base/gsettings-desktop-schemas-0.1.4
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/appstream-0.14.6
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-devel/bison
+ sys-devel/flex
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-link-with-x11.patch
+ "${FILESDIR}"/${PV}-libraw-0.21.patch
+ "${FILESDIR}"/${PV}-date-format.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_use exif exiv2)
+ $(meson_use slideshow clutter)
+ $(meson_use gstreamer)
+ -Dlibchamplain=false # Upstream still doesn't seem to consider this ready
+ $(meson_use colord)
+ $(meson_use tiff libtiff)
+ $(meson_use webp libwebp)
+ $(meson_use jpegxl libjxl)
+ $(meson_use heif libheif)
+ $(meson_use raw libraw)
+ $(meson_use svg librsvg)
+ $(meson_use keyring libsecret)
+ $(meson_use webkit webservices)
+ $(meson_use cdr libbrasero)
+ )
+
+ # colord pulls in lcms2 anyway, so enable lcms with USE="colord -lcms"; some of upstream HAVE_COLORD code depends on HAVE_LCMS2
+ if use lcms || use colord; then
+ emesonargs+=( -Dlcms2=true )
+ else
+ emesonargs+=( -Dlcms2=false )
+ fi
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}