summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-05 09:31:49 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-05 09:32:16 +0200
commit44a6a6dc1f79b0b4b41cd53676ec28652d9a5376 (patch)
treecc67a37f2e63e516283530c89acd4166ac2a1ea7
parentdev-python/nbconvert: add 7.12.0 (diff)
downloadgentoo-44a6a6dc.tar.gz
gentoo-44a6a6dc.tar.bz2
gentoo-44a6a6dc.zip
dev-python/jupyter-server: add 2.11.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jupyter-server/Manifest1
-rw-r--r--dev-python/jupyter-server/jupyter-server-2.11.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/jupyter-server/Manifest b/dev-python/jupyter-server/Manifest
index dbbf00c083a9..702acb520c31 100644
--- a/dev-python/jupyter-server/Manifest
+++ b/dev-python/jupyter-server/Manifest
@@ -1,4 +1,5 @@
DIST jupyter_server-2.10.1.tar.gz 709933 BLAKE2B dd05748eb9e4a1af7adeb8a023c9e1336483f48d32e100f0e8dc8d80bf94afe1fb57343f168828a5856cfa0ccd0f4ffeaa6c0da50e6c98d5ed1f254a87878803 SHA512 15a65df22aa7908d3dd6d694306250e71ddc31b1e66969986ed59d9ed517c28ed474c530916b1de7eab25677f9cec29318798b0b7368c4b37ca92a1adbdfbc8d
DIST jupyter_server-2.11.0.tar.gz 710596 BLAKE2B 61a4d4b23df22625ed0adb5c783e16ee6fe4ee46ffccfd74f0ddf4324056a18c001e4cd1369ee023357cceb6ac73fce6e1cec61d3b6bac7dae2b023806ac59f8 SHA512 fbcc6964ce31cf5285201a91d5a53157bd7feb9c405a8bc6abb64f4373478fbc59de9a8c1e69c27962f04426cd8ef31c2360c549eed4b90fe4d317a4104ed43b
DIST jupyter_server-2.11.1.tar.gz 712608 BLAKE2B 5d33f55d82bca6cb6680f2a44394c6588836e4d63ccfa9b9765582b41f46958e5ffa8949737089b2b3f9673a19c342fd64d9dd962cbecd47cc2ef697c91916c3 SHA512 42822a68efae6385dfd60bc9061310b7d0d38693e6af4a0e8e87b12f0bbc9d88196d1c61e0ee43da5e5fb15033a2de993f27a816bd57f3560ee798893dce90ae
+DIST jupyter_server-2.11.2.tar.gz 712617 BLAKE2B a52518e738869832e87e7f19929b965d207e0078fd081013b758afc9e97cc10acee06c9dd61cb4efe4f1ec5fc2b6797abc45bbc69da4be092aa005f181d335f7 SHA512 625975fa1982657cf048d9fa58436b3e4d7fccfb172234ac92e00db0c388924e564e553d77c863ad3dd26712e15f8244c9f088a34aa21c2b0790161e6f373e9c
DIST jupyter_server-2.9.1.tar.gz 709013 BLAKE2B dee0de771bb8488cccaecb49e2b4a2003f2530243013cafa7f170384380423a7c190504baabf458c59ffece28c4f60662c0530f55535dae25699be269f159743 SHA512 148c3eaa4b6ca1147961c1188e0016a634e5adae350e762903bdde000acde7ab62507e71dbe1278c2b9358ce2cf1c28c17ea8b184f3d4a2d59277910b5b44965
diff --git a/dev-python/jupyter-server/jupyter-server-2.11.2.ebuild b/dev-python/jupyter-server/jupyter-server-2.11.2.ebuild
new file mode 100644
index 000000000000..8a318a5326c5
--- /dev/null
+++ b/dev-python/jupyter-server/jupyter-server-2.11.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_server/
+ https://pypi.org/project/jupyter-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.4.4[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ dev-python/jupyter-server-terminals[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-events-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3.0[${PYTHON_USEDEP}]
+ dev-python/overrides[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/prometheus-client[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
+ >=dev-python/send2trash-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.6.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+
+"
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # This fails if your terminal is zsh (and maybe other non-bash as well?)
+ tests/test_terminal.py
+ # Fails because above is ignored
+ tests/auth/test_authorizer.py
+ # Fails with additional extensions installed
+ tests/extension/test_app.py::test_stop_extension
+ )
+
+ # FIXME: tests seem to be affected by previously installed version
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest \
+ -p pytest_tornasync.plugin \
+ -p jupyter_server.pytest_plugin \
+ -p pytest_console_scripts \
+ -p pytest_timeout
+}