summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-31 05:07:50 +0000
committerSam James <sam@gentoo.org>2021-10-31 05:07:50 +0000
commit44c7a0fe5dc521f4d7e9fb1525d51639f1f563c2 (patch)
tree24ec989b4d2c0aad062866fa83d26607561a8a78
parentnet-misc/spice-gtk: fix finding newer pyparsing (diff)
downloadgentoo-44c7a0fe.tar.gz
gentoo-44c7a0fe.tar.bz2
gentoo-44c7a0fe.zip
net-print/libinklevel: fix autoconf 2.70+ compatibility
Closes: https://bugs.gentoo.org/750173 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-print/libinklevel/files/libinklevel-0.9.2-autoconf-2.70.patch51
-rw-r--r--net-print/libinklevel/libinklevel-0.9.2.ebuild4
2 files changed, 55 insertions, 0 deletions
diff --git a/net-print/libinklevel/files/libinklevel-0.9.2-autoconf-2.70.patch b/net-print/libinklevel/files/libinklevel-0.9.2-autoconf-2.70.patch
new file mode 100644
index 000000000000..462f23eb73b1
--- /dev/null
+++ b/net-print/libinklevel/files/libinklevel-0.9.2-autoconf-2.70.patch
@@ -0,0 +1,51 @@
+https://sources.debian.org/patches/libinklevel/0.9.3-3/0001-configure.ac-fix-ftbfs-with-autoconf2.70.patch/
+https://bugs.gentoo.org/750173
+
+From: Boyuan Yang <byang@debian.org>
+Date: Sat, 16 Jan 2021 11:03:56 -0500
+Subject: configure.ac: fix ftbfs with autoconf2.70
+
+Applied-Upstream: email, yes
+--- a/configure.ac
++++ b/configure.ac
+@@ -12,7 +12,7 @@ ABI_VERSION=5:0:0
+
+ dnl no more configuration after this line
+
+-AC_CONFIG_SRCDIR(libinklevel.c)
++AC_CONFIG_SRCDIR([libinklevel.c])
+
+ ## Determine hostname & OS
+ ## AC_CANONICAL_HOST
+@@ -77,9 +77,9 @@ AC_CHECK_HEADERS([ifaddrs.h])
+
+ ## Check for mandatory header files
+
+-AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h \
++AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h \
+ sys/ioctl.h sys/socket.h sys/time.h sys/timeb.h wchar.h ]
+- ,,AC_MSG_ERROR( required header file missing ))
++ ,,AC_MSG_ERROR([required header file missing]))
+
+ ## determine libraries that need to get linked
+
+@@ -96,7 +96,7 @@ AC_CHECK_FUNCS([getifaddrs])
+ AC_CHECK_FUNCS([alarm ftime gethostbyaddr gethostbyname gettimeofday inet_ntoa \
+ memset select socket strchr strdup strerror strncasecmp strstr \
+ gethostname]
+- ,,AC_MSG_ERROR( required library function missing ))
++ ,,AC_MSG_ERROR([required library function missing]))
+ AC_FUNC_MALLOC
+ AC_FUNC_REALLOC
+ AC_HEADER_RESOLV
+@@ -117,8 +117,8 @@ case $host in
+ PKG_CHECK_MODULES([LIBUSB1], [libusb-1.0]);;
+
+ *-freebsd*) AC_DEFINE_UNQUOTED(HOST_OS,FREEBSD,[Host OS])
+- AC_CHECK_LIB([usb], libusb_init,, AC_MSG_ERROR(Library not found),);;
+- *-*-*) AC_MSG_ERROR( Host OS not (yet) supported) ;;
++ AC_CHECK_LIB([usb], libusb_init,, AC_MSG_ERROR([Library not found]),);;
++ *-*-*) AC_MSG_ERROR([Host OS not (yet) supported]) ;;
+ esac
+
+ ## Variables to be exported
diff --git a/net-print/libinklevel/libinklevel-0.9.2.ebuild b/net-print/libinklevel/libinklevel-0.9.2.ebuild
index b6fb5ca58d72..59afe1969cd3 100644
--- a/net-print/libinklevel/libinklevel-0.9.2.ebuild
+++ b/net-print/libinklevel/libinklevel-0.9.2.ebuild
@@ -21,6 +21,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.2-autoconf-2.70.patch
+)
+
src_prepare() {
sed -i -e "/^dist_doc_DATA/d" Makefile.am \
|| die "Failed to disable installation of docs"