summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-12 17:10:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-12 18:51:39 +0100
commit44c985c21df546d89f4c3679175a3570d1afcc9c (patch)
treebbc313d3e21a226a44331580a7203fc38a92b93c
parentdev-python/pydantic: Bump to 2.6.4 (diff)
downloadgentoo-44c985c21df546d89f4c3679175a3570d1afcc9c.tar.gz
gentoo-44c985c21df546d89f4c3679175a3570d1afcc9c.tar.bz2
gentoo-44c985c21df546d89f4c3679175a3570d1afcc9c.zip
dev-python/fakeredis: Bump to 2.21.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-2.21.3.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 92fd3d40ccae..c1e15263907d 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,2 +1,3 @@
DIST fakeredis-2.21.1.tar.gz 128540 BLAKE2B 042c7189f4437149f099eb2bed9dc93cfaea3eb582dd40aaad55bca6c6c4f679a108b3e36006e537be469a3879085f75e0f5c0c7272d2131c431a4483e15cefc SHA512 ba51079896ca345805a0b2474922a41b7c1526123ac3ff0904d3448512b75515b6b11d7e8ec8fe7abdde94a9ac281aaf56d7344809c18c28ad081af4a542a57b
DIST fakeredis-2.21.2.tar.gz 128965 BLAKE2B 20891c5a34ac5697435a8b05578fc3ffc1a0b008726ed1836929d6e185aff22073382fd0b80d08f4045d85e3d0da9b682900de79b50864ff7682943a634b2970 SHA512 0ba5e31e403670e864a5364498e26e818641d0fbba59554b78bd0d82a2d944a730d519184c132bdb367761b830bb3a55b43a957770f833891cccd11d528ff540
+DIST fakeredis-2.21.3.tar.gz 129013 BLAKE2B 9c56fadc1090cc886fe08b53404c21b1659f4f9c9f5c3c168f02a7ac71e7e660924aec8ad82dbc18d8c2c11245b4548e71ec68d5e83a0a9fd4e5503b85be0cc0 SHA512 aade7596729b7100ef58a2a87cbd011fd4e60970c0c310ca70748e03b787fd3e0ef6d5c54739e91c839f9451a12ec029d441e3cfb4ed3238425b2cce526d8030
diff --git a/dev-python/fakeredis/fakeredis-2.21.3.ebuild b/dev-python/fakeredis/fakeredis-2.21.3.ebuild
new file mode 100644
index 000000000000..916767f1330c
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.21.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}