summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-28 22:30:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-28 22:37:07 +0200
commit44d121fa4b00c3a476626bfa1843de151ebd1de2 (patch)
treec0527c59f69ccaae605b5153179b9e856f728eb3
parentsys-libs/ncurses: avoid egrep/fgrep deprecation warnings (diff)
downloadgentoo-44d121fa.tar.gz
gentoo-44d121fa.tar.bz2
gentoo-44d121fa.zip
dev-python/sphinx-autoapi: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-autoapi/Manifest1
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 55b675cfa7dd..be35a9ccd2b7 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1 +1,2 @@
DIST sphinx-autoapi-1.9.0.gh.tar.gz 84730 BLAKE2B 31547c0dee076736d65867d9856e713581c440d2b1f01b7ebcbe09b31a7bf2979346bcbe18d6064fd5656b7d7dab9149c67fe79f0db7e5757c2581370c11a8cd SHA512 f098f474d9821c974c2ede77de30f3317c87cb87ec00b7a1c021add1d07a1ed59fa3b4165edf2b7f5165004ba9c717394962154098bc89b52989d0e604c542f1
+DIST sphinx-autoapi-2.0.0.gh.tar.gz 86051 BLAKE2B af6c2f997e7e018304c5f19d978fc87fa853d876781930c1220e8e823a078c80c86851a141ed01d7ab94fd76d747e8dfd7462dd5ccab84127f1c95d225324a92 SHA512 7188ed167de808028b2ac603abb6a136584698a1df4882755b80609f4760dab818cec5f4684bf5d16afc2ae1be112ecb96c7f02f989fcb67937c19c045f45b81
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
new file mode 100644
index 000000000000..ed1cb2fd23fd
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/astroid[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+# Test requires pypi download w/ internet: https://github.com/readthedocs/sphinx-autoapi/issues/329
+EPYTEST_DESELECT=(
+ tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample-override_conf2-AutoAPI
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc