summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-12 07:15:53 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-12 07:41:20 +0200
commit44f49c15ba5b8a2bb60d43839c72b89660efcc3f (patch)
treefc299a0861977761c51cb6645f7b33ecf1f66856
parentdev-ruby/git: enable ruby32 (diff)
downloadgentoo-44f49c15.tar.gz
gentoo-44f49c15.tar.bz2
gentoo-44f49c15.zip
dev-ruby/git: drop 1.13.2, 1.16.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/git/Manifest2
-rw-r--r--dev-ruby/git/git-1.13.2.ebuild44
-rw-r--r--dev-ruby/git/git-1.16.0.ebuild42
3 files changed, 0 insertions, 88 deletions
diff --git a/dev-ruby/git/Manifest b/dev-ruby/git/Manifest
index cab1c58ee6f0..1eea2bf73f61 100644
--- a/dev-ruby/git/Manifest
+++ b/dev-ruby/git/Manifest
@@ -1,3 +1 @@
-DIST git-1.13.2.tar.gz 222112 BLAKE2B 13b2f8c67a27a147662fa019f6fac8f557e704fe1d0320188a097385f7692a190670ba375312e793d4d39fcf9ea7be8325394830c2c499b5132201f4a8f3f6ee SHA512 36425806c86e3c5d1a393ec657b60b8dafc88d92822270c299d3d1768c37d00e70b723d98a60127ab70de15809b27a49bcef5c8a972b88d7a516de093a643347
-DIST git-1.16.0.tar.gz 171700 BLAKE2B 92e518a9b282debad9a935882004f8047918ade0ceb660618e632087cfd44fbe952e45f0aa13d8b599e24c07a809622168637b58463578ec5882ec16afe194d5 SHA512 89e9180370b24e0240ba8226125c063ed008faf2c03905e3680a2e5e6b0dcb1d805f17755f259e9337e1418629057ba460e7ecadb8a4c98125a061b7f0116401
DIST git-1.18.0.tar.gz 175341 BLAKE2B 5a8dee1fef79c0386c59d37f37f2249c72600f2f11dbf2cc2c5bf63ff91f068c9c3164d24c2670585e8261d890f07b998255ddb80ce35ce53de09f402a4ec9e3 SHA512 520886b23758229cf25bfdd17e9d86e53d62feb6b2b3c155efe493db42d2f247a29bd629ff6c80ffa599ad429bcb6f09e44b015eeeecf9d9a5f4ee6ab3f1a265
diff --git a/dev-ruby/git/git-1.13.2.ebuild b/dev-ruby/git/git-1.13.2.ebuild
deleted file mode 100644
index 836e97e21a5c..000000000000
--- a/dev-ruby/git/git-1.13.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="git.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Library for using Git in Ruby"
-HOMEPAGE="https://github.com/ruby-git/ruby-git"
-SRC_URI="https://github.com/ruby-git/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="ruby-git-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
-RDEPEND+=">=dev-vcs/git-1.6.0.0"
-
-ruby_add_rdepend ">=dev-ruby/addressable-2.8:0 >=dev-ruby/rchardet-1.8:1"
-
-ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/minitar dev-ruby/test-unit:2 )"
-
-all_ruby_prepare() {
- # Don't use hardcoded /tmp directory.
- sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
-
- sed -i -e 's/__dir__/"."/' -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- sed -i -e 's/1.12.0/'${PV}'/' lib/git/version.rb || die
-}
-
-each_ruby_test() {
- git config --global user.email "git@example.com" || die
- git config --global user.name "GitExample" || die
- ${RUBY} -Ilib:.:test -e 'Dir["tests/**/test_*.rb"].each {|f| require f}' || die
-}
diff --git a/dev-ruby/git/git-1.16.0.ebuild b/dev-ruby/git/git-1.16.0.ebuild
deleted file mode 100644
index c43fd0ab432d..000000000000
--- a/dev-ruby/git/git-1.16.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="git.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Library for using Git in Ruby"
-HOMEPAGE="https://github.com/ruby-git/ruby-git"
-SRC_URI="https://github.com/ruby-git/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="ruby-git-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
-RDEPEND+=">=dev-vcs/git-1.6.0.0"
-
-ruby_add_rdepend ">=dev-ruby/addressable-2.8:0 >=dev-ruby/rchardet-1.8:1"
-
-ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/minitar dev-ruby/test-unit:2 )"
-
-all_ruby_prepare() {
- # Don't use hardcoded /tmp directory.
- sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
-
- sed -i -e 's/__dir__/"."/' -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- git config --global user.email "git@example.com" || die
- git config --global user.name "GitExample" || die
- ${RUBY} -Ilib:.:tests -e 'Dir["tests/**/test_*.rb"].each {|f| require f}' || die
-}