summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-03 13:24:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-03 14:04:48 +0200
commit44fa43981210010435058213a3f6281e695419b0 (patch)
tree5cbd2858b31768f2ce0808bcfbc64fee9f304bb4
parentdev-python/pathlib2: Revived package w/ new upstream, v2.3.7_p1 (diff)
downloadgentoo-44fa4398.tar.gz
gentoo-44fa4398.tar.bz2
gentoo-44fa4398.zip
dev-python/jaraco-text: Bump to 3.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jaraco-text/Manifest1
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.9.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index 1b1229c1e0c7..20746459c826 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1 +1,2 @@
DIST jaraco.text-3.8.1.tar.gz 14160 BLAKE2B 3f8af8881665a8eb9876ae3c76ccaa68f3c58f402e1761956235bda2089e6c5e72f7968ce7fd9dd7b8dc31a08228a715c8c715dc5a93e4453af1b94c2253bce6 SHA512 2dfdd2b3bfef7c0a38a633b810a63a4337ce79b0c871f08beb369bea04585ef1b9e53afa7cef0b54c172ca25eed068af92215526d2f5cee232ccf7e72c914cfa
+DIST jaraco.text-3.9.1.tar.gz 14859 BLAKE2B 39fad64b85c8c1ea7b5bdac963b972b93ddb632940fe873fd0a646ca02d1e3a177742db9099cbbcd07dace1450c23a2e994c36f304a819e98e1c78907af975bd SHA512 f850125c7612342772d5a4a68076ea53a8cad6015c8bbe7e2923b034f8f601c8ff974eec0069b1bacba115d0aa43a948aea3b79f61d773464c823aac1880bbf1
diff --git a/dev-python/jaraco-text/jaraco-text-3.9.1.ebuild b/dev-python/jaraco-text/jaraco-text-3.9.1.ebuild
new file mode 100644
index 000000000000..a909d43c1fd4
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.9.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-5.4.0-r3[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+# needed only for CLI tool, make it PDEPEND to reduce pain in setuptools
+# bootstrap
+PDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/inflect[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}