summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-27 05:38:26 +0100
committerSam James <sam@gentoo.org>2022-08-27 05:38:41 +0100
commit44fb159ff248f157e6808603edeae25719310751 (patch)
tree3fe74a0d67068b651e9d58a00c448508be6aedfe
parentmedia-sound/pianobar: dropped obsolete 2020.04.05 (diff)
downloadgentoo-44fb159f.tar.gz
gentoo-44fb159f.tar.bz2
gentoo-44fb159f.zip
net-misc/openrsync: new package, add 0.5.0_p20220508
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/openrsync/Manifest1
-rw-r--r--net-misc/openrsync/files/openrsync-0.5.0_p20220508-extern-stdint-include.patch11
-rw-r--r--net-misc/openrsync/metadata.xml11
-rw-r--r--net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild40
4 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/openrsync/Manifest b/net-misc/openrsync/Manifest
new file mode 100644
index 000000000000..bd57e5fd9ecd
--- /dev/null
+++ b/net-misc/openrsync/Manifest
@@ -0,0 +1 @@
+DIST openrsync-0.5.0_p20220508.tar.gz 139218 BLAKE2B 2ff7614a10095d01ac46f92281d8e22dd8bd03c943324d4f5eff0f3cd981a5e97a8ce8ee361f8dbd144229c39d29ad33035a704c7e0e753d66eb72ec65c92bed SHA512 f2fec287d57502e3b478652a7c91c38e295221f936eb089f8ecd9efd69e51e0b9896e6f9d5457195db8d4661faf461c34d2d1547373ba5ddae22a5f7135677e9
diff --git a/net-misc/openrsync/files/openrsync-0.5.0_p20220508-extern-stdint-include.patch b/net-misc/openrsync/files/openrsync-0.5.0_p20220508-extern-stdint-include.patch
new file mode 100644
index 000000000000..ea2af659fad2
--- /dev/null
+++ b/net-misc/openrsync/files/openrsync-0.5.0_p20220508-extern-stdint-include.patch
@@ -0,0 +1,11 @@
+--- a/extern.h
++++ b/extern.h
+@@ -17,6 +17,8 @@
+ #ifndef EXTERN_H
+ #define EXTERN_H
+
++#include <stdint.h>
++
+ #if !HAVE_PLEDGE
+ # define pledge(x, y) (1)
+ #endif
diff --git a/net-misc/openrsync/metadata.xml b/net-misc/openrsync/metadata.xml
new file mode 100644
index 000000000000..93a67ab8e286
--- /dev/null
+++ b/net-misc/openrsync/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kristapsdz/openrsync</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild b/net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild
new file mode 100644
index 000000000000..bfbf341c0781
--- /dev/null
+++ b/net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="BSD-licensed implementation of rsync"
+HOMEPAGE="https://www.openrsync.org/"
+
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT="f50d0f8204ea18306a0c29c6ae850292ea826995"
+ SRC_URI="https://github.com/kristapsdz/openrsync/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/kristapsdz/openrsync/archive/refs/tags/VERSION_$(ver_rs 3 _).tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.0_p20220508-extern-stdint-include.patch
+)
+
+src_configure() {
+ tc-export CC
+
+ local confargs=(
+ PREFIX="${EPREFIX}"/usr
+ MANDIR="${EPREFIX}"/usr/share/man
+ )
+
+ edo ./configure "${confargs[@]}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}