summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-04-04 12:44:47 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-04-04 12:44:47 -0500
commit4555ac6f5ce40f6efbcb0e740c2418e1982b808a (patch)
treeecbd3a528025f4ffb7177cc057f9aefc23b204c4
parentapp-containers/grype: drop 0.48.0, 0.51.0 (diff)
downloadgentoo-4555ac6f5ce40f6efbcb0e740c2418e1982b808a.tar.gz
gentoo-4555ac6f5ce40f6efbcb0e740c2418e1982b808a.tar.bz2
gentoo-4555ac6f5ce40f6efbcb0e740c2418e1982b808a.zip
app-containers/syft: add 0.76.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-containers/syft/Manifest2
-rw-r--r--app-containers/syft/syft-0.76.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
index b0478b123501..3b7d246d3e3e 100644
--- a/app-containers/syft/Manifest
+++ b/app-containers/syft/Manifest
@@ -4,3 +4,5 @@ DIST syft-0.59.0-deps.tar.xz 619149756 BLAKE2B acc5118a7d64f5a785d68852984a7c6ab
DIST syft-0.59.0.tar.gz 3784520 BLAKE2B fd6336d886cd9c7052b44df2f86f5ec007ffd16e8e33da9d5bd246a4c0b600a5ecd39edd5e99995aee2ee22c04f5c1fd977bd7a70f799e2638d5bd30d078cda2 SHA512 ecf0eb9b9470bceca918b37895688394d3aa6419561437908d6b9f069f12357f1713d872d139fd704817bb4ea454e5aaa0d8f6c7c8a62d046787aa57606c2cb4
DIST syft-0.75.0-deps.tar.xz 449464772 BLAKE2B 60329a7054917079ea2ad683019933b5a5b02441f7ec6823f64b83fd5c353b7096a21113d91d3b9fc1ecaa0870ccef4ee39c60a250f193bef35e15ea1e1b5598 SHA512 1605a7dd830d648e48049bf918c67bbc542dc790c09097db52e578bb826c994ca0364cc42ae510a6411febd90e395715b8a5317e82d424481ae3b835fae98357
DIST syft-0.75.0.tar.gz 5714462 BLAKE2B 4513fb5ce8c9b432d9042e31c13032428db7ae2b7637f25d391c572094706a1bcfa7dc971a96a8630b3d226504000c79219c0cbc6e1372558c6d08c3ff41dfa4 SHA512 4b8f7cc2823ace1fb2a57a5a989690967ac2b0caf2358dd61a85eca418050ff3fb8ea0409fa694754e595f85168f7f2b192fd407f651f48e05932a73b18fa379
+DIST syft-0.76.0-deps.tar.xz 457367140 BLAKE2B 8d05372361e6051b8102bec3b775eb00f9f24c5d6cddcee39d5d5b0a8f8db5260173d17aa3922b625885c1dddba42f2c2ecb6afe39b03c61a04a9a9577c4a9c6 SHA512 20f32db12c11a15eb323016fb0df09ec0ad823882344006fd30c4450e25feb9db17b8784581a01ed5a3fd68597ad05749082413c4196deff4b908af56c72b04e
+DIST syft-0.76.0.tar.gz 5726316 BLAKE2B debf5c9764994c616fceb7b69c42e87d6399ceb4b2f878935901f626256723177cc3e23b38f6dbce40a59c6586cb5589e82ed3c2a9811117486d9a1ced2f2260 SHA512 86f82455ff0d78864f56f2575bb2acb311ab658c23161b44f342242e88470948581097c2d928fae96ed01ad52843cb26d4682e22e5f81818a83a35cca1eff69e
diff --git a/app-containers/syft/syft-0.76.0.ebuild b/app-containers/syft/syft-0.76.0.ebuild
new file mode 100644
index 000000000000..f2d767a1a229
--- /dev/null
+++ b/app-containers/syft/syft-0.76.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=dfcc07e5122217ca9e2fc75817c593356fc0c405
+
+DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# tests require a running docker daemon
+RESTRICT="test"
+
+src_compile() {
+ local BUILD_DATE
+ BUILD_DATE=$(date -u +%Y-%m-%dT%H:%M:%SZ)
+ ego build -o bin/syft -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/syft/internal/version.version=${PV}
+ -X github.com/anchore/syft/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/syft/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/syft/internal/version.gitDescription=v${PV}
+ " ./cmd/syft
+}
+
+src_install() {
+ dobin bin/*
+}