summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-03 09:30:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-03 09:35:16 +0100
commit455e7bc25f2dc5c4b883168bb05ab29ab216faec (patch)
treedf1261c35ce8167abfdd3b06a51281438bb65e1f
parentdev-java/commons-collections: drop 3.2.2-r1 (diff)
downloadgentoo-455e7bc25f2dc5c4b883168bb05ab29ab216faec.tar.gz
gentoo-455e7bc25f2dc5c4b883168bb05ab29ab216faec.tar.bz2
gentoo-455e7bc25f2dc5c4b883168bb05ab29ab216faec.zip
dev-python/comm: Bump to 0.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/comm/Manifest1
-rw-r--r--dev-python/comm/comm-0.2.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/comm/Manifest b/dev-python/comm/Manifest
index bb06b69e761d..c1c144e9285b 100644
--- a/dev-python/comm/Manifest
+++ b/dev-python/comm/Manifest
@@ -1 +1,2 @@
DIST comm-0.2.0.gh.tar.gz 8936 BLAKE2B 0ca702f3e4aa2a06f827a4896a3497cd98d1e4bafbf9d92942d8d9c6ee8f81b1300a3f2ae72ba32833574444e4d2a4a1fc20be70638333edcbdc2854ee612708 SHA512 6336d9ff2fcf9016d3616ec5c7f6715e8abffc878a0f5b8dabcd06cd17f851cf562e918bd43b55e435adf6da1e635e7152c3b525a5d718b04e7f98b3c8096505
+DIST comm-0.2.1.gh.tar.gz 9569 BLAKE2B 5af0ba4f82ee69819404cef7e45937d9cfeec0a390c7bf562dce1132a7b916a5d8c80c25f7d78cc44f3fb069959d6c8902aae61ecd4bb07e3036d096e25d35cf SHA512 79f85dcd06a5e849718092a3148f39ad81c36a1903a51bd619f50d044cec6be7ca25e3fe7cd85c9174d76558b52dc77a1c3b49f1ed52b8f83e83a8a6ae7f3f0d
diff --git a/dev-python/comm/comm-0.2.1.ebuild b/dev-python/comm/comm-0.2.1.ebuild
new file mode 100644
index 000000000000..6ddbbf5df8d5
--- /dev/null
+++ b/dev-python/comm/comm-0.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+# no tests in sdist, as of 0.1.3
+SRC_URI="
+ https://github.com/ipython/comm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/traitlets-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest