summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 10:11:08 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 10:26:53 +0100
commit457177a5368a0d4c36dd16e0566b6dafb529b8b0 (patch)
tree70c5bafd02f96a6f725c7c25159bfd7839967b82
parentdev-python/priority: Switch to PEP 517 build (diff)
downloadgentoo-457177a5368a0d4c36dd16e0566b6dafb529b8b0.tar.gz
gentoo-457177a5368a0d4c36dd16e0566b6dafb529b8b0.tar.bz2
gentoo-457177a5368a0d4c36dd16e0566b6dafb529b8b0.zip
dev-python/hyperframe: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild b/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild
new file mode 100644
index 000000000000..5854c76ddc16
--- /dev/null
+++ b/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP/2 framing layer for Python"
+HOMEPAGE="https://python-hyper.org/projects/hyperframe/en/latest/
+ https://pypi.org/project/hyperframe/
+ https://github.com/python-hyper/hyperframe/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest