summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-04-28 18:26:22 -0400
committerAaron Bauman <bman@gentoo.org>2018-04-28 18:27:16 -0400
commit4582b31ed2cf4323040ccea113a59009ce46fb06 (patch)
tree74298d761e396e53a53b44f1089553d75f81af83
parentdev-python/markdown: fix HOMEPAGE(s). (diff)
downloadgentoo-4582b31e.tar.gz
gentoo-4582b31e.tar.bz2
gentoo-4582b31e.zip
app-crypt/rhash: add LibreSSL support
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--app-crypt/rhash/metadata.xml3
-rw-r--r--app-crypt/rhash/rhash-1.3.5.ebuild12
-rw-r--r--app-crypt/rhash/rhash-1.3.6-r1.ebuild10
3 files changed, 15 insertions, 10 deletions
diff --git a/app-crypt/rhash/metadata.xml b/app-crypt/rhash/metadata.xml
index 7852b7af67d7..a6651d883c41 100644
--- a/app-crypt/rhash/metadata.xml
+++ b/app-crypt/rhash/metadata.xml
@@ -10,9 +10,6 @@
<remote-id type="github">rhash/RHash</remote-id>
<bugs-to>https://github.com/rhash/RHash/issues</bugs-to>
</upstream>
- <use>
- <flag name='openssl'>Add support for hashes from dev-libs/openssl</flag>
- </use>
<longdescription lang="en">
RHash is a console utility for calculation and verification of magnet links and a wide range of hash sums like CRC32, MD4, MD5, SHA1, SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R 34.11-94, RIPEMD-160, HAS-160, EDON-R, Whirlpool and Snefru.
</longdescription>
diff --git a/app-crypt/rhash/rhash-1.3.5.ebuild b/app-crypt/rhash/rhash-1.3.5.ebuild
index e7fcbe0474f8..dd34f36efb70 100644
--- a/app-crypt/rhash/rhash-1.3.5.ebuild
+++ b/app-crypt/rhash/rhash-1.3.5.ebuild
@@ -12,9 +12,13 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="debug nls openssl static-libs"
+IUSE="debug nls libressl ssl static-libs"
-RDEPEND="openssl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+)"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -50,11 +54,11 @@ multilib_src_compile() {
local ADDCFLAGS=(
$(use debug || echo -DNDEBUG)
$(use nls && echo -DUSE_GETTEXT)
- $(use openssl && echo -DOPENSSL_RUNTIME -rdynamic)
+ $(use ssl && echo -DOPENSSL_RUNTIME -rdynamic)
)
local ADDLDFLAGS=(
- $(use openssl && echo -ldl)
+ $(use ssl && echo -ldl)
)
use elibc_Darwin || use elibc_DragonFly || use elibc_FreeBSD ||
diff --git a/app-crypt/rhash/rhash-1.3.6-r1.ebuild b/app-crypt/rhash/rhash-1.3.6-r1.ebuild
index f5d9f3796faa..24efa6705413 100644
--- a/app-crypt/rhash/rhash-1.3.6-r1.ebuild
+++ b/app-crypt/rhash/rhash-1.3.6-r1.ebuild
@@ -12,9 +12,13 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x64-solaris ~x86-solaris"
-IUSE="debug nls openssl static-libs"
+IUSE="debug nls libressl ssl static-libs"
-RDEPEND="openssl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+)"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -47,7 +51,7 @@ multilib_src_configure() {
--enable-lib-shared \
$(use_enable debug) \
$(use_enable nls gettext) \
- $(use_enable openssl) \
+ $(use_enable ssl openssl) \
$(use_enable static-libs lib-static)
echo "${@}"