summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-20 23:43:39 -0400
committerSam James <sam@gentoo.org>2024-03-21 05:57:38 +0000
commit4586f5f9bbc3786a03d316a4a6a06175c66b362d (patch)
tree5c3c2b35acf434ab4f9d2395a54d4cff522b6766
parentsci-libs/mumps: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-4586f5f9bbc3786a03d316a4a6a06175c66b362d.tar.gz
gentoo-4586f5f9bbc3786a03d316a4a6a06175c66b362d.tar.bz2
gentoo-4586f5f9bbc3786a03d316a4a6a06175c66b362d.zip
dev-python/grpcio: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/856775 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/grpcio/grpcio-1.51.0-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/grpcio/grpcio-1.51.0-r1.ebuild b/dev-python/grpcio/grpcio-1.51.0-r1.ebuild
index c913ad233af6..d6ca281e1887 100644
--- a/dev-python/grpcio/grpcio-1.51.0-r1.ebuild
+++ b/dev-python/grpcio/grpcio-1.51.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 multiprocessing prefix pypi
+inherit distutils-r1 flag-o-matic multiprocessing prefix pypi
DESCRIPTION="High-performance RPC framework (python libraries)"
HOMEPAGE="https://grpc.io"
@@ -38,6 +38,11 @@ python_prepare_all() {
}
python_configure_all() {
+ # -Werror=odr -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/856775
+ # https://github.com/grpc/grpc/issues/36158
+ filter-lto
+
# os.environ.get('GRPC_BUILD_WITH_BORING_SSL_ASM', True)
export GRPC_BUILD_WITH_BORING_SSL_ASM=
export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1