summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2019-11-30 00:22:35 +0000
committerJoonas Niilola <juippis@gentoo.org>2019-12-08 12:08:15 +0200
commit458a5d589ecdce9ee81555700c88f2779d5140ce (patch)
tree195158db320ea89162b749b5c352709becfe987b
parentnet-p2p/resilio-sync: pax-mark unconditionally (diff)
downloadgentoo-458a5d589ecdce9ee81555700c88f2779d5140ce.tar.gz
gentoo-458a5d589ecdce9ee81555700c88f2779d5140ce.tar.bz2
gentoo-458a5d589ecdce9ee81555700c88f2779d5140ce.zip
net-mail/pflogsumm: add support for BDAT
Closes: https://bugs.gentoo.org/699976 Patch-by: Maxim Britov <ungift-ed@ya.ru> Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13804 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-mail/pflogsumm/files/pflogsumm-bdat.patch13
-rw-r--r--net-mail/pflogsumm/pflogsumm-1.1.5-r2.ebuild24
2 files changed, 37 insertions, 0 deletions
diff --git a/net-mail/pflogsumm/files/pflogsumm-bdat.patch b/net-mail/pflogsumm/files/pflogsumm-bdat.patch
new file mode 100644
index 000000000000..fa27b260ac89
--- /dev/null
+++ b/net-mail/pflogsumm/files/pflogsumm-bdat.patch
@@ -0,0 +1,13 @@
+diff --git a/pflogsumm.pl b/pflogsumm.pl
+index 31de5bd..b3bedf9 100755
+--- a/pflogsumm.pl
++++ b/pflogsumm.pl
+@@ -1650,7 +1650,7 @@ sub proc_smtpd_reject {
+ # Next: get the reject "reason"
+ $rejReas = $rejRmdr;
+ unless(defined($opts{'verbMsgDetail'})) {
+- if($rejTyp eq "RCPT" || $rejTyp eq "DATA" || $rejTyp eq "CONNECT") { # special treatment :-(
++ if($rejTyp eq "RCPT" || $rejTyp eq "DATA" || $rejTyp eq "BDAT" || $rejTyp eq "CONNECT") { # special treatment :-(
+ # If there are "<>"s immediately following the reject code, that's
+ # an email address or HELO string. There can be *anything* in
+ # those--incl. stuff that'll screw up subsequent parsing. So just
diff --git a/net-mail/pflogsumm/pflogsumm-1.1.5-r2.ebuild b/net-mail/pflogsumm/pflogsumm-1.1.5-r2.ebuild
new file mode 100644
index 000000000000..8f70f3e92a53
--- /dev/null
+++ b/net-mail/pflogsumm/pflogsumm-1.1.5-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Pflogsumm is a log analyzer for Postfix logs"
+HOMEPAGE="https://jimsun.linxnet.com/postfix_contrib.html"
+SRC_URI="https://jimsun.linxnet.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND="dev-lang/perl
+ dev-perl/Date-Calc"
+
+DOCS=( ChangeLog pflogsumm-faq.txt README ToDo )
+PATCHES=( "${FILESDIR}/${PN}-bdat.patch" ) # Bug 699976
+
+src_install() {
+ default
+ doman pflogsumm.1
+ dobin pflogsumm.pl
+}