summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-20 01:44:58 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-20 01:53:40 +0100
commit458f34dd83af7442fef005222e6fa824d68ff536 (patch)
tree30bf5c761d36a9890455a4af632cef90b46bb63b
parentapp-emacs/corfu: drop old 0.28 (diff)
downloadgentoo-458f34dd.tar.gz
gentoo-458f34dd.tar.bz2
gentoo-458f34dd.zip
app-emacs/corfu: bump to 0.35
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/corfu/Manifest1
-rw-r--r--app-emacs/corfu/corfu-0.35.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/corfu/Manifest b/app-emacs/corfu/Manifest
index 0b078fb625d3..ef51f7ab71c2 100644
--- a/app-emacs/corfu/Manifest
+++ b/app-emacs/corfu/Manifest
@@ -1,2 +1,3 @@
DIST corfu-0.33.tar.gz 44195 BLAKE2B 7995bea510a812ca0772fb2229230ad0f1b1e1ef8ad97e832aa1bd650d7a59b4fe0412fe3f627c37d7027f094a6892856ac02b90aae583c25ce0f03577101ee4 SHA512 e9879a2ecce1fbce9a4750e85f5e5fa998e0f706e67d61b011061275bec7bdb8da3512b4da3d2fbdd6b8dc242887091bf1d68f96a465ee63f9b8e83829b5a3b8
DIST corfu-0.34.tar.gz 44586 BLAKE2B c2a056cdef8cc536f3512662c442504fd3c973649e58b382eb92fb749bc5b3de2dcdad9f13cbe929b33b001fe9fc1ee2b057620c321f32ad9aefc0b274b71983 SHA512 5a46af83eed319170687e91386d8363416682fb6017d465a2b86c8164903efc128122b9cae81482155d8c710f7b2eb1dc8ff0b636544a0a611bec574fdb188c9
+DIST corfu-0.35.tar.gz 45540 BLAKE2B ae5649b3bc5b636887afdd1af7f8b36b9063bc863e72c844f24ad0ede5aacea9f9cab2fbcf0ee543b653f3763d2a0e34097eeadca46c947e483c93ed8cd6619e SHA512 9d749a7e513486b1f83e073083b3c5a35d101c2eb20e4424bc1fe1313ea36469f50eb4c9967b3bb2c9cf249805a57c17843758e8e473f1af5c22987ae47ec404
diff --git a/app-emacs/corfu/corfu-0.35.ebuild b/app-emacs/corfu/corfu-0.35.ebuild
new file mode 100644
index 000000000000..af9057c005cf
--- /dev/null
+++ b/app-emacs/corfu/corfu-0.35.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion Overlay Region FUnction"
+HOMEPAGE="https://github.com/minad/corfu/"
+SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}