summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-09-21 21:52:34 -0400
committerMatt Turner <mattst88@gentoo.org>2023-09-21 22:32:44 -0400
commit459e59082f86336f4d81aa4459e0f7e09bfb4ff7 (patch)
tree9699c9ff19ebde6a9356f8c10b4261a2c2b24614
parentapp-text/evince: Drop old versions (diff)
downloadgentoo-459e59082f86336f4d81aa4459e0f7e09bfb4ff7.tar.gz
gentoo-459e59082f86336f4d81aa4459e0f7e09bfb4ff7.tar.bz2
gentoo-459e59082f86336f4d81aa4459e0f7e09bfb4ff7.zip
dev-libs/gjs: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/gjs/Manifest2
-rw-r--r--dev-libs/gjs/gjs-1.77.2.ebuild68
-rw-r--r--dev-libs/gjs/gjs-1.77.90.ebuild68
3 files changed, 0 insertions, 138 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index a8fbfdc7fb47..56f37acbbaf4 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,4 +1,2 @@
DIST gjs-1.76.2.tar.xz 646232 BLAKE2B 66466eeb5f956d5041f4e63ba977dc9a688455770c39bcedd63576f56fde9821ed3c827c470f7e3befbbf7828fbd197706637da458876ec129d6c16323e414e8 SHA512 26b024874ce69a6f58b5fabe006b8d5417971db9de00e21ecd352715b4535f405d162bb81c0cf6b20313f0f78833962080ac1cb9bd42cfff9cf6a74340458540
-DIST gjs-1.77.2.tar.xz 651784 BLAKE2B 9734fa9c0f4662c1bb233aef9398690295168c5758fe33a27bff5eebb0edee3dad6da28ebeb555337928278c99b5eb7fa1651445bdb8e212d9b672eb9ae08616 SHA512 2b804e6b039801b55e9d700794e390c927b00e2dd738dcada95867b3ba957e1a193367c2babb4a941b8aead301ca68e5b8ece655a13a3989708072a96600eba4
-DIST gjs-1.77.90.tar.xz 653204 BLAKE2B f73ffbd995808a2f8935fd8a0f0700bb9919ffd435d85559729578177b23afb84db30bd8b083a2b9db9c368c088d787994a32a1d638ce3ca5f71c862bfc260ff SHA512 9941680817a6f1d58291b12560bc243e96603ad1eed689fa2f4457343003b818b1f0c1c9c06aec15597b2582395e966eecab19ffd07c87b78d5e355fd675e2f6
DIST gjs-1.78.0.tar.xz 653500 BLAKE2B f2b6c3d80f55c1b3365fdc94dcedec357fc21ec7f92eccdf24cc028eb006538057d0d6e3328bc2f743a563ba496da5daa8585fabd6fbf52acd38c990b8a4e8ba SHA512 28ad3ff5c031b8e78622244918994ca5f510e4b403a382e7d0b0bcb9a0611be61e103398773328be4c405b49d7984c089180a5fb603518b412d01a935fb3ceb3
diff --git a/dev-libs/gjs/gjs-1.77.2.ebuild b/dev-libs/gjs/gjs-1.77.2.ebuild
deleted file mode 100644
index c5181d62024c..000000000000
--- a/dev-libs/gjs/gjs-1.77.2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic gnome.org meson virtualx
-
-DESCRIPTION="Javascript bindings for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
-
-LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
-SLOT="0"
-IUSE="+cairo examples readline sysprof test"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.66.0:2
- dev-libs/libffi:=
- >=dev-libs/gobject-introspection-1.71.1:=
- dev-lang/spidermonkey:115
- cairo? ( x11-libs/cairo[X,glib] )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="${RDEPEND}
- sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
- test? (
- sys-apps/dbus
- >=x11-libs/gtk+-3.20:3[introspection]
- )
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_configure() {
- append-cppflags -DG_DISABLE_CAST_CHECKS
-
- # On musl, it's required that either gjs, pixman or gnome-shell to be built
- # with a larger stack otherwise librsvg fails to render a particular SVG, as
- # a result we fail to get gdm or gnome-shell running (greeted with a fail
- # whale screen). The bug has been reported to librsvg. This is ideally just
- # a temporary workaround until we understand what exactly needs a larger
- # stack size, as it's not sufficient to do just librsvg.
- #
- # Please refer to:
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
- #
- # TODO: Find an actual fix instead of increasing the stack
- use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
-
- # FIXME: add systemtap/dtrace support, like in glib:2
- local emesonargs=(
- $(meson_feature cairo)
- $(meson_feature readline)
- $(meson_feature sysprof profiler)
- -Dinstalled_tests=false
- $(meson_use !test skip_dbus_tests)
- $(meson_use !test skip_gtk_tests)
- -Db_pch=True # TODO this has to go
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}
diff --git a/dev-libs/gjs/gjs-1.77.90.ebuild b/dev-libs/gjs/gjs-1.77.90.ebuild
deleted file mode 100644
index c5181d62024c..000000000000
--- a/dev-libs/gjs/gjs-1.77.90.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic gnome.org meson virtualx
-
-DESCRIPTION="Javascript bindings for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
-
-LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
-SLOT="0"
-IUSE="+cairo examples readline sysprof test"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.66.0:2
- dev-libs/libffi:=
- >=dev-libs/gobject-introspection-1.71.1:=
- dev-lang/spidermonkey:115
- cairo? ( x11-libs/cairo[X,glib] )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="${RDEPEND}
- sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
- test? (
- sys-apps/dbus
- >=x11-libs/gtk+-3.20:3[introspection]
- )
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_configure() {
- append-cppflags -DG_DISABLE_CAST_CHECKS
-
- # On musl, it's required that either gjs, pixman or gnome-shell to be built
- # with a larger stack otherwise librsvg fails to render a particular SVG, as
- # a result we fail to get gdm or gnome-shell running (greeted with a fail
- # whale screen). The bug has been reported to librsvg. This is ideally just
- # a temporary workaround until we understand what exactly needs a larger
- # stack size, as it's not sufficient to do just librsvg.
- #
- # Please refer to:
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
- #
- # TODO: Find an actual fix instead of increasing the stack
- use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
-
- # FIXME: add systemtap/dtrace support, like in glib:2
- local emesonargs=(
- $(meson_feature cairo)
- $(meson_feature readline)
- $(meson_feature sysprof profiler)
- -Dinstalled_tests=false
- $(meson_use !test skip_dbus_tests)
- $(meson_use !test skip_gtk_tests)
- -Db_pch=True # TODO this has to go
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}