summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-09-28 11:30:30 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-28 11:31:49 +0200
commit45d7c2506a364f6a52bb357720496ad6925b51d5 (patch)
tree59ea166608c9b653ad5196e6d3753a415581d6b0
parentapp-vim/ntp-syntax: stable for amd64. mark stable for the remaining arches us... (diff)
downloadgentoo-45d7c250.tar.gz
gentoo-45d7c250.tar.bz2
gentoo-45d7c250.zip
app-vim/dhcpd-syntax: EAPI 6 bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.1
-rw-r--r--app-vim/dhcpd-syntax/dhcpd-syntax-20030825-r1.ebuild15
-rw-r--r--app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch4
2 files changed, 17 insertions, 2 deletions
diff --git a/app-vim/dhcpd-syntax/dhcpd-syntax-20030825-r1.ebuild b/app-vim/dhcpd-syntax/dhcpd-syntax-20030825-r1.ebuild
new file mode 100644
index 000000000000..b5d16e15beb2
--- /dev/null
+++ b/app-vim/dhcpd-syntax/dhcpd-syntax-20030825-r1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting for dhcpd.conf"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=744"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+VIM_PLUGIN_HELPTEXT="This plugin provides syntax highlighting for dhcpd.conf files."
+
+PATCHES=( "${FILESDIR}"/${P}-multiple-addresses.patch )
diff --git a/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch b/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch
index 22eaa8236795..b783792d4cb1 100644
--- a/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch
+++ b/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch
@@ -1,5 +1,5 @@
---- syntax/dhcpd.vim.orig 2005-03-24 16:41:59.755564944 +0000
-+++ syntax/dhcpd.vim 2005-03-24 16:42:15.894111512 +0000
+--- a/syntax/dhcpd.vim 2005-03-24 16:41:59.755564944 +0000
++++ b/syntax/dhcpd.vim 2005-03-24 16:42:15.894111512 +0000
@@ -33,7 +33,7 @@
" Base constructs {{{
syn match dhcpdString +"[^"]*"+