summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-04-28 10:28:29 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-04-28 10:29:55 -0500
commit45fde8d328a100e70c1532942053859fdc2b21ef (patch)
tree77e0b4ab3f59007b837c4b11ff082902e22ea9fb
parentx11-plugins/pidgin-gnome-keyring: new ebuild, initial version 2.0 (diff)
downloadgentoo-45fde8d3.tar.gz
gentoo-45fde8d3.tar.bz2
gentoo-45fde8d3.zip
dev-lang/go: ppc64le updates for #581278
Add proper support for ppc64 to go_arch and display GOROOT_BOOTSTRAP to allow debugging this for new architectures in the future. Package-Manager: portage-2.2.26
-rw-r--r--dev-lang/go/go-1.6.2.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-lang/go/go-1.6.2.ebuild b/dev-lang/go/go-1.6.2.ebuild
index 57ca2c79324b..07d84b0ecdf0 100644
--- a/dev-lang/go/go-1.6.2.ebuild
+++ b/dev-lang/go/go-1.6.2.ebuild
@@ -88,6 +88,8 @@ go_arch()
case "${portage_arch}" in
x86) echo 386;;
x64-*) echo amd64;;
+ ppc64)
+ [[ "$(tc-endian)" = big ]] && echo ppc64 || echo ppc64le ;;
*) echo "${portage_arch}";;
esac
}
@@ -175,6 +177,7 @@ src_compile()
if [[ ${ARCH} == arm ]]; then
export GOARM=$(go_arm)
fi
+ elog "GOROOT_BOOTSTRAP is ${GOROOT_BOOTSTRAP}"
cd src
./make.bash || die "build failed"