summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-10 05:52:34 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-10 05:58:03 +0100
commit465062177c66cc8fd629caa557fbaa5cd46ea5fd (patch)
tree90c1432ba697b7fedc6de0d4265d642188abd20b
parentdev-python/rich: Bump to 11.0.0 (diff)
downloadgentoo-465062177c66cc8fd629caa557fbaa5cd46ea5fd.tar.gz
gentoo-465062177c66cc8fd629caa557fbaa5cd46ea5fd.tar.bz2
gentoo-465062177c66cc8fd629caa557fbaa5cd46ea5fd.zip
dev-python/fastjsonschema: Bump to 2.15.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.15.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 9cb5a91bd84a..d0d649f8e7a2 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST python-fastjsonschema-2.15.1.tar.gz 35384 BLAKE2B 89b9be7a9dcb8b22634dcfb54abec7b5709805b7087558af93b4cbca3c71a0b876956060aac0d0e7f4467db1bb38e6a587025c1c219613a661fb0d9e656b81e0 SHA512 7eb4d512eac03e258d670f6d448c5aeb74e20f892a08fa84a0412fd9c99cdc6412d4daa74bc09f9fe933a973a81227dae36125766e64f3c5b01106435ca5d70f
+DIST python-fastjsonschema-2.15.3.tar.gz 389350 BLAKE2B f9ab32666fce1ba44a11cb981f4f301d7d55260767ec71aefa54ad6bcdd5b8c3d246656908dcd50e909257b35bb9ee24eb34d5ce7fe0f91501127cad412a7e1d SHA512 59dfc513de46e9df790edaa1abc994decdf98d65bec8eb8a6ac7211d2277f4e15d521a308e45c6532a232321d8a4655f87b7a01f2d57b9de20246a4d6deeeb9b
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.15.3.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.15.3.ebuild
new file mode 100644
index 000000000000..5a3028e4da43
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.15.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="https://github.com/horejsek/python-fastjsonschema/"
+SRC_URI="
+ https://github.com/horejsek/python-fastjsonschema/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -r tests/benchmarks || die
+}