summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-04-27 15:33:55 +0200
committerPacho Ramos <pacho@gentoo.org>2023-04-27 15:33:55 +0200
commit4656eaf77527a5c1d0a40a178787458ff56ce068 (patch)
tree42e8fe4dff4af51421ba1b7f2c8c92676d71c57e
parentdev-ruby/histogram: update EAPI 7 -> 8 (diff)
downloadgentoo-4656eaf7.tar.gz
gentoo-4656eaf7.tar.bz2
gentoo-4656eaf7.zip
gnome-extra/gnome-shell-extension-appindicator: Fix duplicated icons
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/files/gnome-shell-extension-appindicator-53-41a8e9c.patch23
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-53-r1.ebuild47
2 files changed, 70 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/files/gnome-shell-extension-appindicator-53-41a8e9c.patch b/gnome-extra/gnome-shell-extension-appindicator/files/gnome-shell-extension-appindicator-53-41a8e9c.patch
new file mode 100644
index 000000000000..9427b16922cd
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/files/gnome-shell-extension-appindicator-53-41a8e9c.patch
@@ -0,0 +1,23 @@
+From 41a8e9c7ff20c0d45ff91a6329455e6f31f2e4aa Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Marco=20Trevisan=20=28Trevi=C3=B1o=29?= <mail@3v1n0.net>
+Date: Mon, 13 Mar 2023 19:07:16 +0100
+Subject: [PATCH] statusNotifierWatcher: Remove idle promise on bus seeking
+
+We're already depending on promises that implies going waiting anyways, so
+we can avoid this.
+---
+ statusNotifierWatcher.js | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/statusNotifierWatcher.js b/statusNotifierWatcher.js
+index fc49639..38fb75a 100644
+--- a/statusNotifierWatcher.js
++++ b/statusNotifierWatcher.js
+@@ -150,7 +150,6 @@ var StatusNotifierWatcher = class AppIndicatorsStatusNotifierWatcher {
+ // StatusNotifierItem interface... However let's do it after a low
+ // priority idle, so that it won't affect startup.
+ const cancellable = this._cancellable;
+- await new PromiseUtils.IdlePromise(GLib.PRIORITY_LOW, cancellable);
+ const bus = Gio.DBus.session;
+ const uniqueNames = await Util.getBusNames(bus, cancellable);
+ const introspectName = async name => {
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-53-r1.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-53-r1.ebuild
new file mode 100644
index 000000000000..909ede60f06a
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-53-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils meson
+
+DESCRIPTION="Support legacy, AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.34
+"
+BDEPEND="
+ app-misc/jq
+"
+
+src_prepare() {
+ default
+ # https://github.com/ubuntu/gnome-shell-extension-appindicator/issues/419
+ eapply -R "${FILESDIR}/${P}-41a8e9c.patch"
+}
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}