summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-08 09:21:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-08 09:43:55 +0100
commit465790f85cce3a8072a4804d6ffd496238c165d0 (patch)
treeb03127c3dd3739b77f69d5c35a21ea399668d90f
parentdev-python/more-itertools: Bump to 8.7.0 (diff)
downloadgentoo-465790f8.tar.gz
gentoo-465790f8.tar.bz2
gentoo-465790f8.zip
dev-python/peewee: Bump to 3.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.14.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index 59cbae45c29b..bfad22ce4f22 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1,2 +1,3 @@
DIST peewee-3.13.2.tar.gz 871323 BLAKE2B 18fd9729ddd6ce3fe4a6963b697815d44e91b5078ba0b868e6b4f24f4cec9c5b01239d7f414f4f8c0871d3dc6bd5e0e37e218c9438cf1f7461bf729cb74049e4 SHA512 7304473f8e64df7cb2205900cfbdd52346d89e9639dc79ed6e13d5c4c11cc856e39e366772039097dc5ca86b4768fa4670dccd96a85cabfb522c463b31c40a8b
DIST peewee-3.14.0.tar.gz 877299 BLAKE2B 25d0027354258c3b2a4db0765f8dac23527816c24afdaf20252e244cfec383a4ae4f10a29ea0f801d5c38406f8c17bcc6fef881b4bce96ed45920a8865868e80 SHA512 083bb24952a6d05cd6c8376e185e050df0ab5b37bc553241128b0ed3b0ebdd322d9626c32943658324d413cff8ab0bb2ddf6c84d99a0fbe057c0e5c8ec93d7f9
+DIST peewee-3.14.1.tar.gz 879443 BLAKE2B f7a1967006e517c56a4a2b10bd9c097e87dca4135038676b096431e6927fa6f0a7e2ad13c036a1a7499a9b3a140a4d4796399f9c1e727e7e8a0770ef3483a3ce SHA512 f8b8bddd1e32e05d75a2f1cc5fcc8b9d98397107e4e4d3b19b444f20f4b8243d740643c858d20fd0ceb8b30de859fe17079fc611ac21cf289c417e1f857f1f0f
diff --git a/dev-python/peewee/peewee-3.14.1.ebuild b/dev-python/peewee/peewee-3.14.1.ebuild
new file mode 100644
index 000000000000..3c298bdb8fbb
--- /dev/null
+++ b/dev-python/peewee/peewee-3.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/psycopg[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}